Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

дано целое число m>10. Получите целое k, при котором k^2<m.

10-11 класс

Ologinova 06 марта 2015 г., 16:07:12 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Geortarasov201
06 марта 2015 г., 17:55:40 (9 лет назад)

var m, k: integer;
begin
     readln(m);
     for k := round(sqrt(m)) downto 0 do
         if (sqr(k) < m) then writeln(k, '^2 < ', m);
end.

Вот так, на Паскале + блок-схема =)

+ 0 -
Tatyanuhka
06 марта 2015 г., 18:49:51 (9 лет назад)

Прогу надо писать??? Если да то в Паскале??

+ 0 -
Gromova0478
06 марта 2015 г., 19:26:58 (9 лет назад)

да, в паскале

Ответить

Читайте также

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

Задачи паскаль, помогите пожалуйста кто. 1, Напишите программу, реализующую следующие вычисления. Дан номер месяца — целое число в диапазоне

1–12, введенное с клавиатуры (1 — январь, 2 — февраль и т. д.). Вывести название соответствующего времени года («зима», «весна», «лето», «осень»).

2, Напишите программу, реализующую следующие вычисления. Дана матрица размера M x N (числа вводятся с клавиатуры). Для каждого столбца матрицы найти произведение его элементов. Полученные значения вывести в текстовый файл.

3, Напишите программу с использованием функции CircleS(R) вещественного типа, находящей площадь круга радиуса R (R — вещественное). С помощью этой функции найти площади трех кругов с данными радиусами. Площадь круга радиуса R вычисляется по формуле S = πR2.

4, Напишите программу, реализующую следующие вычисления. Дано целое число N (1≤N≤26), введенное с клавиатуры. Вывести N первых прописных (то есть заглавных) букв латинского алфавита.

ВЫПОЛНИТЬ В ПАСКАЛЕ! Дано целое число N (> 0). С помощью операций деления нацело и взятия остатка от деления определить, имеется ли

в записи числа N цифра «2». Если имеется, то вывести True, если нет — вывести False.

Заранее спасибо :3



Вы находитесь на странице вопроса "дано целое число m&gt;10. Получите целое k, при котором k^2&lt;m.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.