Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Дано целое число n>2. Получите все простые числа из диапазона [2,n].

10-11 класс

2000danik2000 19 апр. 2014 г., 1:28:44 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lyudmilakucher
19 апр. 2014 г., 3:46:56 (10 лет назад)

Var a, b, k, j: integer;begin     readln(j);     a := 1;     b := 1;     while (j > a) do     begin          k := b;          b := b + a;          a := k;     end;     writeln(a);end.

+ 0 -
Olя17
19 апр. 2014 г., 6:04:27 (10 лет назад)

public int gcd(int x, int y) {         if(y == 0) return x;         if(y ==  x) Concole.Write(x + " ";)  // выводим простое число         return gcd(y, x % y); } // вызов gcd(2,n);

Ответить

Другие вопросы из категории

На двух первых днях рождениях у пяточка Винни-Пух съел всего 100г пищи.Составить програму ,которая определяет,сколько килограммов пищи съест Винни-Пух

на 15 дне рождении,если на каждом следующим дне рождении он съедает столько сколько на предыдущих.обрати внимание что граммы надо образовать в кг.

Читайте также

помогите коле и напишите программу или алгоритм которое находит все просые числа в диапазоне от m до N ВКлючительно

в задаче требуется написать программу которая по двум заданным числам находила бы в диапазоне между этими числами все простые числам где простое число которое имеет всего лишь два делителя то есть оно делится на единицу и на само себя и больше оно не на что не делиться например -3 7 11 помогите )) олимпиада по инфе )) даю максимум баллов ))

1.дано целое k>2. напечатать все простые числа из диапазона [2,k]

2.найти первое число Фибоначчи, большее заданного n (n>1).

Дана строка , в которой содержится осмысленное текстовое сообщение. Слова сообщения разделяются В заданном формате дд- целое число из диапазона от 1 до

31, мм - целое число из диапазона от 1 до 12, а гг - целое число из диапазона от 1 до 2020 (если какая-то часть формата нарушена, то данная подстрока в качестве даты не рассматривается.) Заменить каждую дату сообщения на дату следующего дня. Написать программу на Паскале. Сроооооооооооооочнооо. Пооожалуйста.....

10-11 класс информатика ответов нет
1. Получить все шестизначные числа, в диапазоне от 0 до 999999, у которых сумма первых трех цифр

равна сумме последних трех цифр. Если в числе меньше шести цифр, то оно слева дополняется нулями.

Помогите пожалуйста! Задание: 1) Укажите через запятую в порядке возрастания все десятичные числа, не превосходящие 25, запись которых в

троичной системе счисления оканчивается на 21?

2) укажите через запятую в порядке возрастания все десятичные числа, не превосходящие 45, запись кторых в двоичной системе счисления оканчивается на 1010?

3) Укажите сколько всего раз встретится цифра 3 в записи чисел 13, 14,15,...,23 в системе счисления с основанием 4?



Вы находитесь на странице вопроса "Дано целое число n>2. Получите все простые числа из диапазона [2,n].", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.