Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Здравствуйте! Позарез нужна программа в Паскале, вот условие:

10-11 класс

"Разработать программу,
которая осуществляет в текстовом файле поиск заданных слов. Слова
последовательно вводятся с клавиатуры. Для каждого слова должно определяться
количество вхождений и номера строк текста. Если указанное слово в файле
отсутствует, то программа должна выводить соответствующее сообщение."
И если можно, то и блок-схему.
Заранее спасибо!

Millav 10 янв. 2015 г., 18:33:57 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Yana0514
10 янв. 2015 г., 19:55:39 (9 лет назад)

var
  c: string;
  d: byte;
  b: boolean;

begin
  readln(c);
  foreach a: string in System.IO.File.ReadAllLines('in.txt') do
  begin
    d += 1;
    b := false;
    if (pos(c, a) > 0) then
    begin
      b := true;
      writeln('Вхождение! Строка №', d, '. Количество вхождений: ', (a.Length - a.Replace(c, '').Length)/c.Length);
    end;
  end;
  writeln(not b ? 'There aren`t :(' : '');
end.

Тут получится сухая блок-схема, но длинная... Воть
Не люблю их

Ответить

Читайте также

Ребята, девчата, тут такое затруднение. Нужна программа в паскале, только в паскале.

Условие:
Напишите программу которая вычисляет среднее арифметическое элементов таблицы А(3*8) . Программа по двумерным массивам.

В прямоугольной системе координат даны координаты A (3 3), B (-42 14) C (-2 4)

Найти координаты точки М, где М - середина ВС



Нужна программа в паскале, помогите пожалуйста.



Вы находитесь на странице вопроса "Здравствуйте! Позарез нужна программа в Паскале, вот условие:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.