Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Дается произвольное количество чисел, нужно найти количество чисел оканчивающихся на цифру 6 ( по программе паскаль)

5-9 класс

9195788 11 мая 2015 г., 6:25:31 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
агент000007
11 мая 2015 г., 7:52:37 (9 лет назад)

var a,i,n: integer;
begin
readln (n);
for i:= 1 to n do
begin
readln (a);
if a mod 10= 6 then
k:=k+1;
end;
writeln (k);
end.

+ 0 -
Zelenoglazkaaa
11 мая 2015 г., 8:59:40 (9 лет назад)

var
n, i, a: integer;

begin
readln(n);
for i:=1 to n do
 begin
  read(a);
   if inttostr(a)[length(inttostr(a))]='6' then write(a, ' ');
 end;
 end.

Где n - кол-во чисел. Вводится первым. Затем вводится n чисел.

+ 0 -
Molinamolly
11 мая 2015 г., 11:26:56 (9 лет назад)

Принялся.

Ответить

Другие вопросы из категории

Читайте также

Напишите программу, которая в последовательности целых чисел определяет количество чисел, кратных 4 и оканчивающихся на 0. Программа получает на вход целые

числа, количество введеных чисел неизвестно, последовательность чисел заканчивается числом 0 (0-признак окончания ввода, не является членом последовательности). Количество чисел не превышает 1000. Введеные числа по модулю не превышают 30000. Программа должна вывести число: количество чисел, кратных 4 и оканчивающихся на 0.

напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех чисел кратных 7 и оканчивающихся на 0. Программа получает на

вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0- признак окончания ввода, не входит в последовательность), Количество чисел не превышает 1000. Введенные числа не превышают 30000. Программа должна вывести одно число: сумму всех чисел, кратных 7 и оканчивающихся на 0. Программу надо написать в Pascal

Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, оканчивающееся на 3. Программа получает на вход

количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 3. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число – максимальное число, оканчивающееся на 3. Пример работы программы: Входные данные Выходные данные 3 23 13 23 3

Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, оканчивающееся на 4. Программа получает на вход

количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 4. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число – минимальное число, оканчивающееся на 4.

Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, оканчивающееся на 6. Программа получает на вход

количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 6. Количество чисел не превышает 1000. Введенные числа не превышают 30 000. Программа должна вывести одно число минимальное число, оканчивающееся на 6.



Вы находитесь на странице вопроса "Дается произвольное количество чисел, нужно найти количество чисел оканчивающихся на цифру 6 ( по программе паскаль)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.