Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

написать на паскале программу генератора случайных чисел. помогите срочно надо.

5-9 класс

Kseniya56069 09 апр. 2017 г., 9:17:24 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Cпартак
09 апр. 2017 г., 10:28:03 (7 лет назад)

var 

 n, min, max, i: integer;  {min - минимальное значение диапазона, max - максимальное, n - количество генерируемых случайных чисел}

 

begin

  writeln('Введите, сколько нужно сгенерировать случайных чисел');

  readln(n);

  writeln('Введите, в каком диапазоне генерировать случайные числа');

  readln(min, max);

  randomize;

  for i:= 1 to n do

    writeln(random(max - min) + min);

end. 

  

+ 0 -
Alinaermoshkina
09 апр. 2017 г., 12:14:14 (7 лет назад)

var ch

Ответить

Другие вопросы из категории

Соствьте программу,...
Начав тренировки, спортсмен пробежал в первый день 10 км.Каждый день он увеличивал дневную норму на 10% нормы предыдущего дня.Сколько он пробегал за

каждый день тренировки? Какой суммарный путь пробежит спортсмен за 7 дней?
Написать программу в Паскале

Помогите Пожалуйстаа!!!!!!

Как сделать объемную фигуру в программе ЧЕРТЁЁЁЖНИК???????
ПОЖАЛУЙСТА,дайте мне координатыы)

Читайте также

I В паскале с помощью генератора случайных чисел получить двузначное число и

1) найти и вывести сумму его цифр
2) сформировать число, в котором поменяются разряды (допустим будет число 13, нужно сделать, что бы было 31 и т.п.)
II В паскале с помощью генератора случайных чисел получить трехзначное число и определить, является ли оно полимером (например 121 - является, 123 - нет)

I В паскале с помощью генератора случайных чисел получить двузначное число и

1) найти и вывести сумму его цифр
2) сформировать число, в котором поменяются разряды (допустим будет число 13, нужно сделать, что бы было 31 и т.п.)
II В паскале с помощью генератора случайных чисел получить трехзначное число и определить, является ли оно полимером (например 121 - является, 123 - нет)

Помогите сослать программу на Паскале.Поиск чисел в массиве. Program Example;

{Программа заполняет массив Rand случайными числами в диапазоне от 0 до 50,
вводит число Х, и вычисляет, сколько раз Х входит в массив Rand}

Var Rand: array[1..20] of integer;
I, X, NumberX : integer,
Begin
{Установка датчика случайных чисел}
​Randomize;
{Заполнение массива случайными числами и вывод их на экран}
​Writeln(‘Массив случайных чисел:’)
​For I:=1 to 10 do
​begin
​ Rand[I]:=random(50); Write(Rand[I]:4)
​End;
​Writeln;
{Ввод Х}
​Write(‘Введите Х:’)); Readln(X);
{Подсчет числа вхождений Х в массив}
​NumberX:=0;
​For I:=1 to 10 do
​​If Rand(I)=X then NumberX:=NumberX+1;
{Анализ и вывод результата}
​If NumberX=0
​Then​writeln(‘В массиве нет числа’,X)
​Else writeln(‘Число’,X,’в массиве присутствует’,NumberX,’раза’)
End.

Написать на Паскале программу, которая запрашивает с клавиатуры N произвольных целых чисел и ищет их сумму. Число N вводится с клавиатуры. Разработать для

созданной программы не менее трех тестов и проверить на них правильность работы алгоритма.
БЕЗ МАССИВА
ПОЖАЛУЙСТА
+194884839383948 К КАРМЕ ТОМУ КТОНАПИШЕТ



Вы находитесь на странице вопроса "написать на паскале программу генератора случайных чисел. помогите срочно надо.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.