Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Трехзначное число, записанное в шестнадцатеричной системе счисления, увеличива-ется вдвое от перестановки первой цифры в конец числа. Определите

10-11 класс

максимальное из таких чисел, записанное в системе счисления по основанию 16.

Даринок 22 мая 2013 г., 0:22:17 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Eke4913
22 мая 2013 г., 2:27:56 (10 лет назад)

var
  i,j,k,ix,jx,kx:integer;
  s:string;

function per(x:integer):string;
begin
case x of
  10: result:='A';
  11: result:='B';
  12: result:='C';
  13: result:='D';
  14: result:='E';
  15: result:='F';
  else
    str(x,result);
  end;
end;

begin
for i:=1 to 15 do
  for j:=0 to 15 do
    for k:=0 to 15 do
      if 2*(i*16*16+j*16+k)=j*16*16+k*16+i then
         begin
         ix:=i;
         jx:=j;
         kx:=k;
         end;
s:=per(ix)+per(jx)+per(kx);
writeln(s);     
end. 

В результате работы программы получаем ответ.
Ответ: 6DB

Ответить

Другие вопросы из категории

когда мы переписываемся, мы

часто исползуем цифры в нашем тексте. васм дано одно предложение не англиском
языке. Нужно найти все цифры, которые встречаются в этом предложенний хотябы бы
один раз






































изображение имеет размер 10*10см с разрешением 1000*1000dpi и только 65536 возможных цвета.какой обьем памяти займет оно в мегабайтах? картинка 200*100

пикселей имеет 256 различных оттенков.сколько памяти она займет в КБ?

Читайте также

Сколько существует различных пар натуральных чисел, таких что: 1. Оба числа, записанные в семеричной системе счисления, имеют ровно по три значащих

разряда. 2. Сумма этих чисел, записанная в семеричной системе счисления, содержит только цифры «1». Пары чисел, отличающиеся только порядком следования чисел в паре, считаются одинаковыми. В ответе укажите целое число.

СРОЧНО! ПОМОГИ! ПОЖАЛУЙСТА!!!!!! №1. В системе счисления с некоторым основанием десятичное число 43 записывается в виде «111». Укажите это

основание

№2. Укажите через запятую в порядке возрастания все основания систем счисления, в которых запись десятичного числа 53 оканчивается на 3.

№3. Укажите через запятую в порядке возрастания все числа, не превосходящие 30, запись которых в двоичной системе счисления оканчивается на «101». Числа в ответе указывайте в десятичной системе счисления.

№4. Количество единиц в двоичной записи числа 12, 25 равно…

№5. Для кодирования букв А,Б,В,Г решили использовать двухразрядные последовательные двоичные числа (от 00 до 11 соответственно). Если таким образом закодировать последовательность символов ГБАВ и перевести результат в шестнадцатеричную систему счисления, то получится…

№6. Как представляется десятичное число 13,5 в двоичной системе счисления?

№7. Как представляется десятичное число 416 в восьмеричной системе счисления?

№8. Как представляется десятичное число 523 в шестнадцатеричной системе счисления?

№9. Вычислите значение суммы 1012 + 118 + 1016. Результат представьте в виде десятичного числа.

№10. Вычислите значение разности двух чисел 1116 – 118. Результат представьте в виде десятичного числа.

1)Дано : a=F716 , b= 3718 . Какое из чисел С, записанных в двоичной системе счисления, удовлетворяет неравенству aC b ?

А) 111110012 Б) 110110002 В) 111101112 Г) 111110002
2)Дано : a= DD16 , b = 3378 . Какое из чисел С, записанных в двоичной системе счисления, удовлетворяет неравенству aC b ?
А) 110110102 Б) 111111102 В) 110111102 Г) 110111112
3)Дано : a=EA16 , b = 3548 . Какое из чисел С, записанных в двоичной системе счисления, удовлетворяет неравенству aC b ?
А)111010102 Б) 111011102 В) 111010112 Г) 111011002
4)Дано : a=3228 , b =D416 . Какое из чисел С, записанных в двоичной системе счисления, удовлетворяет неравенству aC b ?
А) 110100112 Б) 110011102 В) 110010102 Г) 110011002
5)Дано : a= D116 , b= 3338 . Какое из чисел С, записанных в двоичной системе счисления, удовлетворяет неравенству aC b ?
А)111000112 Б) 110110102 В) 101011012 Г) 110111012
ПОМОГИТЕ ПОЖАЛУЙСТА!

• Перевести данное число из десятичной системы счисления в двоичную, восьмеричную и шестнадцатеричную системы счисления:


1) 164.25
2) 520,375

• Перевести данное число в десятичную систему счисления:
1) 1110010100,1011001 (двоичная СС)
2) 1000000110,00101 (двоичная СС)
3) 666,16 (восьмеричная СС)
4) 1C7,68 (шестнадцатеричная СС)
*СС - система счисления.

Заданы 2 значения натурального числа N(0<=N<=100000000), записанные в десятичной системе счисления с неизвестным основанием A(2<=A<=16).

Написать программу на, которая определяет неизвестное основание системы счисления.



Вы находитесь на странице вопроса "Трехзначное число, записанное в шестнадцатеричной системе счисления, увеличива-ется вдвое от перестановки первой цифры в конец числа. Определите", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.