Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

1.Дано целое двузначное число. Написать программу которая находит квадрат суммы его цифр. pascal

5-9 класс

Dsgf 12 июля 2016 г., 13:00:42 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lyaysan11
12 июля 2016 г., 13:54:51 (7 лет назад)

program qwerty;
var a, b, c, d:integer;
begin
writeln ('Нахождение квадрата суммы цифр двузначного числа');
writeln ('Введите число ');
readln (a);
b:= a mod 10;
a:= a div 10;
c:= a mod 10;
a:= a div 10;
d:= sqr (b + c);
writeln ('Ответ: ', d)
end.

+ 0 -
абильмансур
12 июля 2016 г., 16:04:37 (7 лет назад)

в Pascal?

+ 0 -
гшпшпгнпншш
12 июля 2016 г., 18:36:29 (7 лет назад)

да

Ответить

Другие вопросы из категории

Помогите пожалуйста написать прогу, заранее спасибо)

Заполните массив случайными числами от 0 до 4(вывести его на экран) и выведите на экран номера тех элементов, значения которых равны х(х вводится с клавы)

как человек хранит информацию????

какими свойствами обладает память человека??
чем отличается память человека от памяти человечества????
как люди хранят информацию различных видов?приведите примеры?

Между командами ввода и вывода впишите в алгоритм несколько команд присваивания, в результате чего должен получиться алгоритм возведения в 4-ю с

тепень введенного числа(дополнительные переменные, кроме А,не использовать.

Ввод А

Вывод А

Читайте также

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат

1.Дано целое число составить программу которая определяет оканчивающие данное число цифрой семь.

2.Дано 2х значное число составить программу с помощью которой можно отпределить входит ли в это число цифра шесть.

Пожалуйста помогите решить желательно все или хотя бы одну (P.S. программа для программы Turbo Pascal) 1.Написать программу, которая предлагает

ввести 3 значное число и находит сумму его цифр.

2. Написать программу, которая предлагает ввести 3 значное число и меняет порядок цифр наоборот. (123- 321)

3.Написать программу, которая предлагает ввести три числа с клавиатуры, находит их сумму, произведение и среднее арифметическое.

Помогите плиз срочно 1)Написать программу,которая спрашивает"Который час?" и,в зависимости от введенного времени,выводит приветствие:"Доброе

утро","Добрый день","Добрый вечер", "Спокойной ночи". 2)Написать программу,которая определяет,принадлежит ли точка с координатами (x,y)Заштрихованной области,ограниченной точками(x1,y1)(x2,y2).

1. Даны два различных вещественных числа X и Y. Написать программу, возведения наименьшего из чисел в квадрат, наибольшего – в куб и нахождения среднего

арифметического полученных значений.
2. За весну Обломов похудел на p1 кг, за лето поправился на p2 кг, за осень похудел на p3 кг, за зиму поправился на p4 кг. Написать программу, определяющую, похудел или поправился за год Обломов.
3. Написать программу, которая определяет, является ли целое число четным двузначным числом.
4. Даны коэффициенты квадратного уравнения. Написать программу, определяющую его корни



Вы находитесь на странице вопроса "1.Дано целое двузначное число. Написать программу которая находит квадрат суммы его цифр. pascal", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.