Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Дана квадратная матрица 9-ого порядка. Получить квадратную матрицу того же порядка, в которой элемент равен единице, если соответствующий ему элемент исход

5-9 класс

ной матрицы меньше элемента, расположенного в его строке на главной диагонали, и равен нулю в противном случае.

Monokini9 16 авг. 2016 г., 19:53:48 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Barsigor6311
16 авг. 2016 г., 22:51:50 (7 лет назад)

const
  n = 9;

var
  a: array[1..n, 1..n] of integer;
  i, j, aii: integer;

begin
  Randomize;
  Writeln('Исходный массив');
  for i := 1 to n do
  begin
    for j := 1 to n do
    begin
      a[i, j] := Random(101) - 50;
      Write(a[i, j]:4)
    end;
    Writeln
  end;
  Writeln('Результирующий массив');
  for i := 1 to n do
  begin
    aii:=a[i,i];
    for j:=1 to n do
    begin
      if a[i,j]<aii then a[i,j]:=1 else a[i,j]:=0;
      Write(a[i,j]:4)
    end;
    Writeln
  end
end.

Тестовое решение:
Исходный массив
 -11  19  48  32  -6 -39 -45 -13 -27
  44  20 -44  27 -50  14 -19 -12  32
   2  48 -16  40  -8 -38  35 -15  41
  -1 -24 -18  35 -49 -11  22  -4  -1
  36 -26  -8  -2  -9 -17  41  44 -13
   0 -25  -6 -35 -18  -6 -28  46  44
   5  -1 -23  36  47 -41 -30   7 -39
  41 -41  19  17 -45   5 -35  -4 -36
 -11 -46   6 -50  49  -2  26 -15 -40
Результирующий массив
   0   0   0   0   0   1   1   1   1
   0   0   1   0   1   1   1   1   0
   0   0   0   0   0   1   0   0   0
   1   1   1   0   1   1   1   1   1
   0   1   0   0   0   1   0   0   1
   0   1   0   1   1   0   1   0   0
   0   0   0   0   0   1   0   0   1
   0   1   0   0   1   0   1   0   1
   0   1   0   1   0   0   0   0   0



Ответить

Другие вопросы из категории

Информатика

фото внутри
буду благодарна

Петя загадал последовательность из 4 чисел, в которой каждое следующее число на единицу больше предыдущего. После этого он записал каждое число в системе

счисления с определенным основанием, не меняя порядка чисел. Все числа записаны в системах счисления с разными основаниями. Получилась следующая запись:23 22 21 20Определите, в какой системе счисления записано последнее число, если известно, что одно из чисел записано в четверичной системе счисления. В ответе укажите натуральное число, равное основанию этой системы счисления.

В хронологическом порядке перечень этапов развития информационной технологии:

а) ручная, механическая, электронная, электрическая, компьютерная;
б) каменная, механическая, электронная, электрическая, компьютерная;
в) ручная, механическая, электрическая, электронная, компьютерная;
г) ручная, механическая, электрическая, компьютерная, электрическая
технология

Читайте также

Дана квадратная матрица. Получить одномерный массив состоящий из средних арифметических элементов строк матрицы. Полученный одномерный массив

отсортировать в порядке возрастания элементов. Вывести:

- матрицу
- одномерный массив до сортировки
- одномерный массив после сортировки прошу. срочно!

Помогите пожалуйста !!!!Написать программу на языке Pascal решения квадратного уравнения. Программа должна проверять правильность введенных

пользователем данных и в случае, если коэффициент при второй степени неизвестного равен нулю, выводить соответствующее сообщение.

Напишите программу, которая находит в матрице столбцы, в которых есть элемент, равный максимальному.

Входные данные
В первой строке записаны через пробел размеры матрицы: количество строк N и количество столбцов M ( 1 ≤ N , M ≤ 100 ). В следующих N строках записаны строки матрицы, в каждой – по M натуральных чисел, разделённых пробелами.

Выходные данные
Программа должна вывести все столбцы, в которых есть элемент, равный максимальному элементу в матрице. Каждый столбец выводится в одну строку, элементы разделяются пробелами.

Дан следующий алгоритм (символом := обозначается операция присваивания): Ввести a, b

a:=a+b

b:=a-b

a:=a-b

Вывести a+b

Расположите исходные данные для этого алгоритма в порядке ВОЗРАСТАНИЯ результатов.

1) a=10 , b=8

2) a=4 , b=12

3) a=7 , b=7

4) a=6 , b=9

5) a=9 , b=11

Петя и Коля пишут друг другу электронные письма в кодировке КОИ-8. Однажды Петя ошибся и отправил письмо в кодировке Windows. Коля получил письмо и,

как всегда, прочитал его в КОИ-8. Получился бессмысленный текст, одно из предложений которого имело вид: кЧАЮЪ ХМТНПЛЮЖХЪ ЛНФЕР АШРЭ ОПЕДЯРЮБКЕМЮ Я ОНЛНЫЭЧ ВХЯЕК.



Вы находитесь на странице вопроса "Дана квадратная матрица 9-ого порядка. Получить квадратную матрицу того же порядка, в которой элемент равен единице, если соответствующий ему элемент исход", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.