Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Даны натуральные числа M и N (M <= N< 31). Найти число сочетаний из N по M.

5-9 класс

Kendra22 18 марта 2017 г., 10:01:37 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sosed515
18 марта 2017 г., 12:48:56 (7 лет назад)

В этой программе вычисляются все C из N по M для N,M<30. Если жалко память - можно хранить только 1 строчку, если жалко время - можно считать каждую строку только до M-ого слагаемого и остановиться, когда дойдём по N-ой строки.
Если помнить, что C из N по M = C из N по N-M, тоже можно немного сэкономить.

Ответить

Другие вопросы из категории

Перед вами программа к задаче "Вводить пары чисел, пока первое число больше второго".

var a,b:integer;
begin
while a>b do
begin
writeln('Введите пару чисел');
readln(a,b);
end;
writeln('условие нарушилось');
end.
Найдите и исправьте ошибку в программе.

какие процессы в природе и технике относятся к информационным?

А) ток "бежит" по проводам
Б) запись на диск
В) цветок распускается
Г) птица поет

Читайте также

1)Даны два целых числа A и B (A < B). Найти сумму квадратов всех целых чисел

от A до B включительно.
2)Даны натуральные числа от A до B(A<B). Найти произведение тех из них, которые делятся на 3 и не делятся на 4.
3)Ангелина узнав, что Боря занимается спортом, решила не отставать. Она каждый день делала от 3 до 5 упражнений на икры (вводится во время выполнения программы) и 5 упражнений на пресс. Сколько упражнений она сделала за 5, 10 и 13 дней. (количество упражнений на икры на каждый день вводится отдельно)


дано натуральное число N, Написать ему выводящую на экран последовательность натуральность натуральных чисел от 1 до N, задание 2 дано натуральное число

N, Написать ему выводящую на экран последовательность натуральность натуральных чисел отN до 1, номер 3 Даны натуральные числа N и К.Написать программу выводящую на экран последовательность из N чисел , каждое из которых равно К хотя бы что нибудь решите помогите очень надо!!!!!!!!!

Даны два целых числа A и B (A < B). Вывести в порядке убывания все

целые числа, расположенные между A и B (не включая числа A и B), а
также количество N этих чисел.

имеется фрагмент текста,содержащий лишние пробелы:<<Алгоритмом_называется _ _набор _ _ _инструкций,_ описывающих_ _ _

_порядок_действий_исполнителя...>>За какое наименьшее количество операций <<Найти и заменить все>> двух подряд идущих пробелов одним мы сможем избавиться от лишних пробелов?
а)5
б)2
в)3
г)4



Вы находитесь на странице вопроса "Даны натуральные числа M и N (M &lt;= N&lt; 31). Найти число сочетаний из N по M.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.