Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

помогите решить образцы есть

10-11 класс

Sidinka 18 дек. 2016 г., 14:15:10 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Madinka9600
18 дек. 2016 г., 15:43:18 (7 лет назад)

program kolvo_el;   
const n=20; 
  var a:array[1..n] of integer;
       i,k:integer;
 begin
 randomize;
 k:=0;
 for i:=1 to n do begin 
 a[i]:=random(15); 
 write (a[i],' ');
 if a[i]<5 then k:=k+1;
 end;
 writeln; 
 writeln ('k=',k); 
 end.

Ответить

Другие вопросы из категории

Найти значение: min(P1, P2), где

P1 – скалярное произведение векторов A и B.
P2 – скалярное произведение векторов C и D.
Вычисление скалярного произведения векторов оформить подпрограммой.
Исходные данные: А=(-5.1, 2.7, 3.4, 6.2); В=(1.2, 3.4, 0, 2.5);
С=(2.7, 3.4, 2.5, 6.3, 7.8); D=(1.7, -1.3, 2.8, 0, 7.2);

ОЧЕНЬ СРОЧНО!!!!! ПОЖАЛУЙСТА

Надо выполнить работу в экселе ЗАДАНИЕ №8 ТОЛЬКО!!!!!!

Читайте также

Помогите решить задачу.

Дан массив А1,.......Аn. найти максимальный и минимальный элементы и поменять их местами. Вот задача которую я делал:

program zadacha;
const
k=50;
var
a:array[1..k] of integer;
n,i:1..k;
c,v,max,min,prom:integer;
begin
for i:=1 to n do begin (здесь выскакивает ошибка о проверки диапазона)
a[i]:=random(50);
write(a[i],' ');
end;
max:=a[1];
min:=a[1];
for i:=1 to n do begin
if a[i]>max then begin
max:=a[i];
c:=i;
end;
if a[i]<min the begin
min:=a[i];
v:=i;
end;
end;
writeln('max=',max,'min=',min);
prom:=max; (вот с этой строчки и до конца помогите решить)
max:=min;
min:=prom;
writeln;
writeln('Полученный массив');
for i:=1 to n do
write(a[i], ' ');
readln;
end.

Помогите решить на паскале

______________________________________
В сказочном Солнечном городе живут трое братьев: Ниф-Ниф, Наф-Наф, и Нуф-Нуф. Известно, что у каждого из них есть какое-то количество денег. Так случилось, что после физкультуры они перепутали пиджаки, в которых и лежали деньги. Однако зная о возможной путанице родители пришили бирки с именами. Помогите определить сколько же денег было до физкультуры у братьев, зная что Нуф-Нуф пришел домой в пиджаке Ниф-Нифа, а Наф-Наф в пиджаке Нуф-Нуфа. Входные данные:

В единственной строке входного потока, через пробел записано три числа в диапазоне от 1 до 10^9. Первое число это количество денег, которое обнаружил Ниф-Ниф в карманах придя домой. Второе - сколько стало у Наф-Нафа. И третье сколько принес домой Нуф-Нуф.

Выходные данные:

В первую строку выходного потока необходимо вывести сколько денег было у Ниф-Нифа, во вторую - сколько у Наф-Нафа, а в третью - сколько у Нуф-Нуфа.

Пример входного файла (input.txt): 32 22 54 Пример выходного файла (output.txt): 54 32 22

срочно помогите решить! дам много пунктов!!! пожалуйста, зачет по информатике!! в qBasiq Вариант №

1

Дан массив целых чисел, состоящий из 20 элементов. Заполнить его с клавиатуры.

1. Найти:

- сумму элементов, имеющих нечетное значение;

- вывести индексы тех элементов, значения которых больше заданного числа А.

2. Определить, есть ли в данном массиве положительные элементы, кратные k (k вводить с клавиатуры).

Помогите решить задачу Известно, что имеющийся на каждой шкатулок надписи либо истина либо ложь. Если надпись на 1-ой шкатулке(и зумрудов в друго

й шкатулке нет), а на 2-ой шк.(в той шк. изумруды есть, а в этой нет) то определить в какой шкатулке изумруд.



Вы находитесь на странице вопроса "помогите решить образцы есть", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.