Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Вывести на экран элементы массива которые являются делителями числа Х (Х-вводится с клавиатуры). (Элементов массива:10. Массив вводится cлучайным образом)

10-11 класс

решите пожалуйста и опишите полностью, только решение должо быть простым не через процедуры а то я на 1 курсе мы еше это не проходили)

Alikzamok 07 янв. 2017 г., 6:18:37 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Moloko20491
07 янв. 2017 г., 8:08:03 (7 лет назад)

var

  a:array [1..10] of integer;

  i,x:integer;

begin

  randomize;

  for i:=1 to 10 do 

   begin

    a[i]:=random(14)+1;

    write (a[i],' ');

   end;

  writeln;

  write ('X = ');readln(x);

  for i:=1 to 10 do

   if x mod a[i] = 0 then write (a[i],' ');

  writeln;

  readln;

end.

Ответить

Другие вопросы из категории

Помогите пожалуйста)Желательно подробно.

Ниже записан алгоритм. Получив на ход число x этот алгоритм , запишет две буквы M,L. Напишите число “x” при котором алгоритм с начало напишет число 2, а потом 8 .
DIM X, L, M AS INTEGER
INPUT X L=0: M=0
WHILE X>0
L=L+1
IF M<(X MOD 10) THEN M=X MOD 10
END IF
X=X\10
WEND
PRINT L, M

в паскале:
var x, L, M: integer;
begin
readln(x);
L:=0; M:=0;
while x > 0 do
begin
L:=L+1;
if M < (x mod 10) then begin
M:=x mod 10;
end;
x:= x div 10;
end;
writeln(L);
write(M);
end.

помогите решить образцы есть

Читайте также

1)ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива

2) ввести с клавиатуры массив из n элементов вывести на экран максимальный четный элемент и минимальный нечетный элемент

1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.

1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы

каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3. Ввести массив с клавиатуры, найти и вывести сумму элементов массива. 4. Ввести массив с клавиатуры, подсчитать, сколько в нем положительных элементов, а сколько отрицательных. 5. В одномерном массиве подсчитать, сколько отрицательных элементов находится на четных местах и сколько положительных на нечетных. 6. Элементы массива вводятся с клавиатуры, заменить в нем все отрицательные элементы их квадратами, а положительные кубами. Вывести на экран исходный и новый массив. 7. Ввести массив с клавиатуры, найти и вывести на экран максимальный и минимальный элементы. 8. Написать программу, которая определяет есть ли в массиве элемент введенный пользователем, подсчитывает их количество и выводит номер первого найденного элемента.

дан целостный массив из 30 элементов. элементы массива могут принимать целые значения от 0 до 100 опишите на русском языке или одном из языков

программирования алгоритм позволяющий найти и вывести номер элемента массива имеющего максимальное значение сре элементов массива которые делятся на 3 и кратны 5



Вы находитесь на странице вопроса "Вывести на экран элементы массива которые являются делителями числа Х (Х-вводится с клавиатуры). (Элементов массива:10. Массив вводится cлучайным образом)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.