Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Даны две точки в плоской прямоугольной системе координат. Составить программу в паскале для определения, которая из точек находится ближе к началу

5-9 класс

координат.(СРОЧНО. ЗАРАНЕЕ СПАСИБО)

Артём19960905 23 апр. 2013 г., 3:34:51 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dana2014Dana
23 апр. 2013 г., 5:56:20 (11 лет назад)

var
  x, y, d : real;
begin
  read (x, y);
  d := sqr (x) + sqr (y);
  read (x, y);
  if d > sqr (x) + sqr (y) then write ('Вторая ближе') else write ('Первая ближе');
end.

Ответить

Другие вопросы из категории

Pascal. Написать такую программу:

На вход получает N - количество элементов последовательности чисел.
Затем следуют элементы последовательности.
Программа должна вывести все отрицательные элементы последовательности, чьи квадраты не превосходят 7000, в порядке, обратном порядку их ввода.
Например на вход идут:
4
-3
6
-7
-99

На выходе получаем:
-7
-3

Я предлагаю такое начало программы:

program num9;
const N = 5;
var a : array [1..N] of integer;
i, m : integer;
begin for i := 1 to N do
readln (a[i]);
m := a[i];
if (m < 0) and (m*m < 7000) then

Как следует поступить дальше?

Сегодня в индийском городке

Старый Гоа отмечают День святого Франциска Ксавьера. Святой Франциск Ксавьер –
миссионер, член ордена иезуитов, считается величайшим католическим миссионером
Нового времени.

Мощи святого Франциска Ксавьера
– духовного покровителя индийских христиан – покоятся в Старом Гоа в известном
католическом храме – Базилике Бом Иисус. Со дня постройки храма в 1605 году раз
в десять лет мощи святого выставляются для всеобщего обозрения.

Индийский крестьянин Вирмарам –
человек очень набожный, он не упускал случая коснуться святых мощей. Зная годы
его жизни, определите, сколько раз он мог коснуться святых мощей (считается,
что в год своего рождения он не мог этого сделать, а в год смерти – мог).

Входные данные

Вводятся два натуральных числа
– год рождения и год смерти. Числа разделены пробелом.

Выходные данные

Программа должна определить,
сколько раз крестьянин мог коснуться святых мощей, и вывести ответ - одно
число.




Примеры Входной
файл. Input.txt

СРОЧНО

С помощью Паскаля:
1.В магазине продается мастика в ящиках по 15 кг,17 кг,21 кг. Как купить ровно 185 кг мастики, не вскрывая ящики?Сколькими способами можно это сделать?

Читайте также

Даны две точки в плоской прямоугольной системе координат. Напишите программу, определяющую, которая из точек находится ближе к началу координат.

Примеры входных данных: координаты 1-ой точки>> 1,2..

координаты 2-ой точки>> 3,4..

Примеры выходных данных: 1-ая точка ближе...Помогите пожалуйста.

Пожалуйста помогите решить кроссворд :)

По горизонтали: 3 . Французский математик, в честь которого названа прямоугольная система координат. 6 . Способ кодирования информации с помощью чисел. 8. Способ кодирования информации с помощью символов того же алфавита,что и исходный текст. 9 . Представление информации с помощью некоторого кода. 10. Игра,в которой фигуры перемещаются по клеткам с координатами.
По вертикали: 1. Один из удобных способов представления графической информации с помощью чисел. 2. Способ кодирования информации с помощью рисунков или значков. 4. Французский педагог , придумавший специальный способ представления информации для слепых. 5.Система условных знаков для представления информации (множественное число) :))



Вы находитесь на странице вопроса "Даны две точки в плоской прямоугольной системе координат. Составить программу в паскале для определения, которая из точек находится ближе к началу", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.