Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

даны координаты двух точек A(x1,y2) и B(x2,y2) в прямоугольной системе координат.Какая из этих двух точек находится дальше от начала координат?

5-9 класс

Olgabelous2015 30 окт. 2013 г., 5:30:45 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Emmi24
30 окт. 2013 г., 7:13:14 (10 лет назад)

var
x1,x2,y1,y2:real;
begin
writeln('Введите координаты точки А');
readln(x1,y1);
writeln('Введите координаты точки В');
readln(x2,y2);
if (sqrt(sqr(x1)+sqr(y1)))>(sqrt(sqr(x2)+sqr(y2)))  then
writeln('А дальше')
else
if (sqrt(sqr(x1)+sqr(y1)))<(sqrt(sqr(x2)+sqr(y2)))  then
writeln('В дальше')
else
writeln('Расстояние одинаковое');
end.

Ответить

Другие вопросы из категории

составить программу заполнения массива а[1..10] следующими числами:индекс массива 1 2 3 4 5 6 7 8 9 10

значение элемента 1 6 3 12 5 18 7 24 9 30

закономерность- значения элементов с нечетными индексами равны индексу элемента,а значения элементов с четными индексами-утроенному индексу элемента

нужно он var то end.



Пожалуйста помогите!! очень срочно, нужно написать программу скорей всего мне кажется в паскале

1. Writel(' вести стоимость перчатки наприм')
read (x)
2 стоимость сумки- наприм.
3.стоимость ремня- наприм.
4.если общая сумма больше 800р, то вывести сумму с учетом 10% скидки
5.если сумма меньше 800р, то вывести сумму
Помогите пожалуйста очень нужно, благодарю!!!

Помогите пожалуйста решить номер 164,165

Заранее благодарю

В числе,записанном в римской системе счисления,поменяли местами вторую и третью,четвертую и пятую от начала цифры,а затем перевели результат в

десятичную систму счисления. Получилось число 2162. Определите исходное число,переведите его в десятичную систему счисления и запишите результат.Напомним чтодля записи чисел в римской системе счисления используют набор из семи цифр(I,V.X,L,C,D,M) ответы ввиде тестов.

а)1924

б)1492

в)1294

г)1942

ПОМАГИТЕ МНЕ РЕШИТЬ ПОЖАЛУЙСТА!!!

Читайте также

№19. Даны стороны треугольника. Определить является ли этот треугольник: а) равносторонним б) равнобедренным в) прямоугольным.

№20. Даны величины углов треугольника. Определить является ли это треугольник:

а) остроугольным

б) тупоугольным

в) прямоугольным

г) равносторонним

д) равнобедренным.

№21. Определить, какая из двух точек - M1(x1,y1) или M2(x2,y2) - расположена ближе к началу координат. Вывести на экран дисплея координаты этой точки.

№22. Даны действительные числа a, b, c, x, y. Выяснить, пройдет ли кирпич с ребрами a,b,c в прямоугольное отверстие со сторонами x и y. Просовывать кирпич в отверстие разрешается только так, чтобы каждое из его ребер было параллельно или перпендикулярно каждой из сторон отверстия.

№23. Написать программу, которая печатает True или False в зависимости от того, выполняются или нет заданные условия:

а) квадрат заданного трехзначного числа равен кубу суммы цифр этого числа;

б) сумма двух первых цифр заданного четырехзначного числа равна сумме двух его последних цифр;

в) среди цифр заданного трехзначного числа есть одинаковые;

г) среди первых трех цифр из дробной части заданного положительного вещественного числа есть цифра 0.

Даны две точки в плоской прямоугольной системе координат. Напишите программу, определяющую, которая из точек находится ближе к началу координат.

Примеры входных данных: координаты 1-ой точки>> 1,2..

координаты 2-ой точки>> 3,4..

Примеры выходных данных: 1-ая точка ближе...Помогите пожалуйста.

2 задачи по программированию: 1) Три точки заданы своими координатами (x1,y1),

(x2,y2), (x3,y3). Напишите программу, позволяющую выяснить, какие из них находятся на максимальном расстоянии друг от друга, и вывести на печать значение этого расстояния. Вычисление расстояния между двумя точками оформите в виде процедуры.

2) Даны действительные числа Х и Y. Напишите программу, позволяющую вычислить значение следующего выражения:

Z=(signX + signY)*sign(X+Y),



Вы находитесь на странице вопроса "даны координаты двух точек A(x1,y2) и B(x2,y2) в прямоугольной системе координат.Какая из этих двух точек находится дальше от начала координат?", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.