Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

дан массив 0из 6 элементов. найти среднее арифметического элементов этого массива. в паскале

10-11 класс

Warface1564 26 июля 2015 г., 20:04:36 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alinka032
26 июля 2015 г., 20:59:29 (8 лет назад)

const n = 6;
var
a: array[1..n] of integer;
i, s: integer;
begin
for i := 1 to n do begin
a[i] := random(20);
s := s + a[i];
write(a[i], ' ');
end;
writeln;
writeln('Среднее арифметическое эл. массива: ', s / n);
end.

+ 0 -
Катюха21
26 июля 2015 г., 22:13:03 (8 лет назад)

Program Tanina_domashka;

  i:byte;

  summa:integer;

  o:array[1..6] of integer;

 Begin

 Writeln('Массив');

 For i:=1 to 6 do

  Begin

    o[i]:=random(1001)-500;

    Writeln('Элемент массива №',i,' = ',o[i]);

  End;

 For i:=1 to 6 do

   summa:=summa+o[i];

 Writeln('Среднее арифметическое элементов массива = ',summa/6);

 End.

Ответить

Другие вопросы из категории

Определить значение целочисленной переменной а и b после выполнения фрагмента программы:

a:=2599;
b:=(a mod 10)*1000+26;
a:=(b div 10) mod 100;

1) a=26, b=9026; 2) a=2, b=9026; 3) a=26, b=9926; 4) a=2, b=9926.

Заполнить массив из 10 элементов случайными числами в интервале [0...10] и выполнить циклический сдвиг массива ВПРАВО.

Формат ввода и вывода данных:
Исходный массив:
4 -5 3 10 -4 -6 8 -10 1 0
Результат:
0 4 -5 3 10 -4 -6 8 -10 1

Читайте также

1)дан одномерный массив из 5 элементов.найти сумму положительных элементов. 2)Дан одномерный массив из 7

элементов.Найти колличество четных положительных элементов.

3)Дан массив из 6 элементов.Найти произвдение положительных из них.

Добрый день. Помогите пожалуйста решить две задачи... №1 Дан массив из 25 элементов,найти сумму 4-х наибольших и 4-х наименьших э

лементов. Результат распечатать в виде:

Сумма наибольших=

Сумма наименьших=

№2

Даны два массива по 30 элементов. Найти среднее арифмитическое для элементов 1-го массива,номера которых больше номера минимального элемента 2-го массива

Заранее спасибо

дан массив из семи элементов написать программу подсчитывающую

среднее второго и предпоследнего элементов массива
дан целочисленный
массив из 10 элементов написать программу находящую сумму элементов
массива красных 3 ил 5
дан целочисленный массив из 30 ти элементов
написать программу которая позволяет найти среднее арифметическое
положительных элементов массива



Вы находитесь на странице вопроса "дан массив 0из 6 элементов. найти среднее арифметического элементов этого массива. в паскале", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.