Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Заполнить массив из 10 элементов случайными числами в интервале [0...10] и выполнить циклический сдвиг массива ВПРАВО.

10-11 класс

Формат ввода и вывода данных:
Исходный массив:
4 -5 3 10 -4 -6 8 -10 1 0
Результат:
0 4 -5 3 10 -4 -6 8 -10 1

Natkasol 24 июня 2015 г., 1:39:02 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
натальянаталья
24 июня 2015 г., 2:51:12 (8 лет назад)

const
  n = 10;

var
  i, s: integer;
  a: array[1..n] of integer;

begin
  Writeln('Введите элементы массива через пробел');
  for i := 1 to n do Read(a[i]);
  s := a[n];
  for i := n downto 2 do a[i] := a[i - 1];
  a[1] := s;
  for i := 1 to n do Write(a[i]:4);
end.

Тестовое решение:
Введите элементы массива через пробел
4 -5 3 10 -4 -6 8 -10 1 0
   0   4  -5   3  10  -4  -6   8 -10   1

Ответить

Другие вопросы из категории

Один из часто встречающихся видов списка стек — список, в котором все операции включения и извлечения, сопровождающегося удалением из списка, элементов

выполняются только с одного края. Механизм функционирования стека отражён в его названии «LIFO» (Last In First Out — последним вошёл, первым вышел, подобно патронам в обойме). Следовательно, любой элемент не может быть извлечён и удалён из стека раньше, чем будут извлечены все элементы, помещённые в стек позднее него. Составить программу, реализующую функционирование стека. Стек оформить как массив.

Читайте также

Помогите пожааалуйста,вообще нереально сделать(задачи зависят друг от друга) 1.заполнить массив из 100 элементов случайными числами.вывести на

экран с 20 по 50 в строку через пробел

2.для первыз десяти элементов найти среднее арифмитическое

3.вывести на экран только четные элементы с 1 по 10 элементы массива

4.найти сумму нечетныз значений с 20 по 50 элемент

5.найти количество элементов кратныз заданному числу,введёного с клавиатуры среди всез элементок линейного массива

Помогите, пожалуйста!

заполнить массив из 9 элементов случайными числами в интервале в интервале [10,150] и найти min элемент массива, у которых вторая с конца цифра- нечетная



Вы находитесь на странице вопроса "Заполнить массив из 10 элементов случайными числами в интервале [0...10] и выполнить циклический сдвиг массива ВПРАВО.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.