Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

При проектировании БД были определены следующие отношения: МАГАЗИН (Номер_магазина, Тип, Адрес, Директор, Телефон) ; ОТДЕЛ (Название_отд, Заведующий,

10-11 класс

Телефон) ; ПРОДАВЕЦ (Табельный_ном. , Фамилия, Имя, Отчество, Категория) Являются ли эти отношения связанными? Добавьте всё, что необходимо для их связи; изобразите схему БД в графическом виде.

Artur200017 03 авг. 2013 г., 0:15:16 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ramazanov1989x
03 авг. 2013 г., 2:23:13 (10 лет назад)

Исходные отношения не связаны. Необходимые поля для связи добавлены (см. вложение). Примечание: PK - Primary Key (первичный ключ).

Ответить

Другие вопросы из категории

Задача первая.

Дан массив O ( K ). Заменить все положительные числа квадратом числа,а отрицательные модулем.
Задача вторая.
Дан массив R ( 6 ) .Найти сумму и произведение всех элементов массивов.

Через Qbasic

ОТ CLS ДО ЕND

Найдите четыре младших разряда троичного представления числа (2008^1899 +1900^2007 +17)3 . тройка в конце означает что число записано в троичной

системе счисления.(то есть тройка маленькая внизу) . Подразумевается решение через Бином Ньютона. не могу сообразить

Помогите пожалуйста!) Напечатать программу в паскале......

Пожалуйста...Срочно...Завтра крайний срок сдачи...Помогите...

Дан массив строк без пробелов. Напечатать строки, вторая половина которых не содержит цифры.

Читайте также

Помогите пожалуйста!!! Кто чем может :)

При проектировании БД были определены следующие отношения: МАГАЗИН (Номер_магазина, Тип, Адрес, Директор, Телефон) ; ОТДЕЛ (Название_отд, Заведующий, Телефон) ; ПРОДАВЕЦ (Табельный_ном. , Фамилия, Имя, Отчество, Категория) Являются ли эти отношения связанными? Добавьте всё, что необходимо для их связи; изобразите схему БД в графическом виде.

1. а) Для чего предназначены базы данных? Выберите верный ответ:

для выполнения вычислений на компьютере;

для осуществления хранения, поиска и сортировки данных;

для принятия управляющих решений.

б) Какие существуют варианты классификации БД?

в) Почему реляционный вид БД является наиболее распространенным?

г) Что такое запись в реляционной БД?

д) Что такое поле, тип поля; какие бывают типы полей?

е) Что такое главный ключ записи?

2. Определите главный ключ и типы записей в следующих отношениях:
АВТОБУСЫ (НОМЕР МАРШРУТА, НАЧАЛЬНАЯ ОСТАНОВКА,
КОНЕЧНАЯ ОСТАНОВКА)

КИНО (КИНОТЕАТР, СЕАНС, ФИЛЬМ, РОССИЙСКИЙ, ДЛИТЕЛЬНОСТЬ)

УРОКИ (ДЕНЬ НЕДЕЛИ, НОМЕР УРОКА, КЛАСС, ПРЕДМЕТ, ПРЕПОДАВАТЕЛЬ)

Определите следующие понятия: имя

поля, значение поля, тип поля. Какие бывают типы полей? Какие величины определяет каждый из типов? Пожалуйста напишите подробненько,а то щас ОЧЕНЬ НАДО. завтра сдавать задания по информатике. Сижу уже 1 час ночи засыпаю!!! ЗАРАНЕЕ СПАСИБО!!!

Числа Фибоначчи определяются следующими формулами: f0=f1=1;

fn=fn-1+fn-2, при n>=2 на вход программе подается целое неотрицательное n=<40 выведите n-е число Фибоначчи. Массив в программе не использовать

№1

Требовалось написать программу, которая определяет, имеется ли среди введенных с клавиатуры положительных целых чисел а и Ь хотя бы одно четное. Была написана следующая программа:

•​ var a, b: integer;

•​ begin

•​ readln(a, b);

•​ a := a mod 2;

•​ if a > 0 then b := b mod 2;

•​ if b > 0 then

•​ writeln ('четных чисел нет')

•​ else

•​ writeln ('четное число есть');

•​ end.

Доработайте эту программу таким образом, чтобы задача решалась верно.

№2

С клавиатуры вводится трёхзначное число. Нужно вывести ответ «Да», если все его цифры четные, и ответ «Нет» в остальных случаях. Если введено не трёхзначное число, должно быть выведено сообщение «Неверное число».



Вы находитесь на странице вопроса "При проектировании БД были определены следующие отношения: МАГАЗИН (Номер_магазина, Тип, Адрес, Директор, Телефон) ; ОТДЕЛ (Название_отд, Заведующий,", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.