Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Составить программу одномерного массива.

10-11 класс

подсчитать количество чисел,не принадлежащих промежутку (х,у]

444elena1 26 июня 2014 г., 0:48:07 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Shelmix
26 июня 2014 г., 3:15:24 (9 лет назад)

program Program1;
var Arr: array[-100..100] of integer;
Arr2: array[-100..100] of integer;
i, n, x, y: integer;
begin
     randomize;
     write('Введите количество элементов в массиве: ');
     readln(n);
     for i := 1 to n do Arr[i] := random(100) - random(100);
     writeln('Весь массив: ');
     for i := 1 to n do write(Arr[i], ' ');
     writeln();
     write('Введите X и Y: ');
     read(x, y);
     for i := 1 to x - 1  do write(Arr[i], ' ');
     for i := y + 1 to n  do write(Arr[i], ' ');
end.

+ 0 -
Dornanrei
26 июня 2014 г., 5:46:16 (9 лет назад)

во вложении
спрашивайте, что непонятно

+ 0 -
Valanin2012
26 июня 2014 г., 8:07:04 (9 лет назад)

исходный одномерный массив

+ 0 -
Lamaua
26 июня 2014 г., 10:51:45 (9 лет назад)

а х и у?

+ 0 -
Ludmilafin74
26 июня 2014 г., 13:48:00 (9 лет назад)

есть пример ввода?

+ 0 -
Zenya00
26 июня 2014 г., 14:23:01 (9 лет назад)

Да сначала n,потом массив,а потом х и у

+ 0 -
Tanyacake1
26 июня 2014 г., 16:20:29 (9 лет назад)

сейчас исправлю

Ответить

Другие вопросы из категории

Автоматическое устроиство осуществило перекодировку информационного сообщения на русском языке ,первоначально записанного в 16-битном коде Unicode,в

8-битную кодировку КОИ-8.Насколько байт уменьшился при этом информационный объем сообщения?

!!!ПОМОГИТЕ РЕШИТЬ!!!
Операторы. Вводы. Вывода.

Решение подобно на второй фотографии
Спасибо огромное заранее

Читайте также

1. Составьте программу ввода и вывода массива: 5, -2, 3, -6, 7, 9, -4, 8, 1, 2, 7, -3.

2. Составьте блок-схему алгоритма и программу вычисления в массиве A(10) количества положительных элементов.
3*. Составьте программу заполнения массива, не используя клавиатуру, числами: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19.

Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом

массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

Составить блок-схему алгоритма и программу на алгоритмическом языке программирования БЕЙСИК обработки одномерного массива. Заполнение массива элементами

организовать путем ввода с клавиатуры. В одномерном массиве из N натуральных чисел вычислить сумму удвоенных четных чисел.

Помогите составить блок-схему алгоритма и программу на алгоритмическом языке программирования БЕЙСИК обработки одномерного массива.Заполнение массива

элементами организовать путем ввода с клавиатуры.В одномерном массиве из N чисел вывести на экран отрицательные элементы и сообщите об их количестве.Пожалуйста,срочно надо.



Вы находитесь на странице вопроса "Составить программу одномерного массива.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.