Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Имеется таблица вещественных чисел B[1:1020]. Составить алгоритм, по которому положительные числа будут заменены на 1, а отрицательные на 0 и подсчитать

5-9 класс

количество 1 в таблице

Ксенька171202 11 мая 2015 г., 2:12:12 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Natalyabagno
11 мая 2015 г., 3:51:42 (9 лет назад)

const n = 1; m = 1020;
var
  b: array [1..n, 1..m] of real;
  i, j, c: integer;
begin
  randomize;
  for i := 1 to n do
    for j := 1 to m do
      b[i, j] := Random(1001) - 500;
  
  for i := 1 to n do
    for j := 1 to m do begin
      b[i, j] := (Sign(b[i, j]) + 1) shr 1;
      c := c + Trunc(b[i, j]);
    end;
    
  writeln(c, ' единиц.');
end.

Ответить

Другие вопросы из категории

Читайте также

Составьте алгоритм, по которому на компьютере будет происходить следующее: в переменную S вводится возраст Саши, в переменную М вводится возраст Маши. В

качестве результата на экран выводится фраза "Саша старше Маши" или "Маша старше Саши" (предполагаем, что кто-нибудь из них обязательно старше).

Составьте алгоритм, по которому на компьютере будет происходить следующее: в переменную S вводится возраст Саши, в переменную М вводится возраст Маши. В

качестве результата на экран выводится фраза "Саша старше Маши" или "Маша старше Саши"

1) составить логическое условие, которое истинно только тогда, когда лишь одно из 3-х чисел больше 10.

2) составить логическое условие, которое истино только тогда, когда данное число чётное, натуральное не больше 100.
3) Даны 3 вещественных числа a/b/c/, все четные числа рзделить на 2, все не четные оставить без изменения.

Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, делящееся нацело на 7 . Программа получает на вход

количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, делящееся нацело на 7.
Количество чисел не превышает 1000. Введеные числа не превышают 30 000.
программа должна вывести одно число - минимальное число, делящееся нацело на 7.
Завтра Гиа помогите!!!

автоматическое устройство имеет один вход,можно подавать на него натуральные числа или последовательности символов и наблюдать результат на выходе. По

таблице наблюдений определите тип входных данных и правило, по которому осуществляется их преобразование



Вы находитесь на странице вопроса "Имеется таблица вещественных чисел B[1:1020]. Составить алгоритм, по которому положительные числа будут заменены на 1, а отрицательные на 0 и подсчитать", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.