Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

вычислите значение функции y=x^3-x^2+16x-43 для x изменяющегося в диапазоне от-4 до 4 включительно с шагом 0.5. Нужно написать на Паскале

10-11 класс

GlebDmitriev 07 янв. 2014 г., 22:54:20 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Numaster
08 янв. 2014 г., 0:00:41 (10 лет назад)

program task;
var i,a:real;
begin     
i:=-4;     
while (i<=4) do begin           
a:=(i*i*i)-(i*i)+16*i-43;           
writeln(a:0:2);           
i+=0.5;     
end;     
readln;
end.

Ответить

Другие вопросы из категории

Добрый день. Помогите пожалуйста решить две задачи... №1 Дан массив из 25 элементов,найти сумму 4-х наибольших и 4-х наименьших э

лементов. Результат распечатать в виде:

Сумма наибольших=

Сумма наименьших=

№2

Даны два массива по 30 элементов. Найти среднее арифмитическое для элементов 1-го массива,номера которых больше номера минимального элемента 2-го массива

Заранее спасибо

пожалуйста помогите подскажите как делать такое задание в delphi

Нужно СЕГОДНЯ итак надо по номеру дня недели определить чем вы занимаетесь в свободное время.Можно написать любые занятия.
3 разные виды занятия.
Описать когда свободное время ,тоесть действия не определены.

Решите головоломку.Если в слове А его вторую половину, буквы которой образуют слово В, заменить на слово С, то получится слово Д. Причем: А - фрагмент

оперативной памяти размером в 16 байтов; В – конечное число точек на плоскости, соединённых отрезками кривых линий; С – единица измерения расстояния; Д – аргумент или результат процедуры.В ответе запишите найденные слова: сначала А, затем, В, С и Д, через один пробел, без знаков препинания.

Читайте также

1)написать программу, которая вычисляет произведение сумм всех соседних пар целых чисел из диапазона от 12 до 36 и выводит значения тех сумм, которые

меньше 52.

2)В результате работы некоторой подпрограммы вычислены значения четырех переменных a, b, c, d. Написать на предложенном в пункте а) языке программирования программу, после работы которой в случае, если сумма положительных значений (среди a, b, c, d) больше 20, значение g равно наибольшему из a, b, c, а в остальных случаях значение g равно значению d. (В программе можно использовать новые переменные.)

Задание: разработать программу вычисления выходного значения функ-ции y=f(x1,x2,x3,x4). Тип входных и выходных данных, вид функции заданы в табл. 2.

Выходное значение и входные должны отображаться на экране в виде: X1= X2= X3= X4= Y=

Разработать функцию, которая автоматически заполняет массив из 10 наборов входных данных. Массив затем подвергается обработке, т.е. в цикле вычисляются значения функции и выводятся на экран в виде: Y1= Y2= Y3= Y4= , и т.д.

тип входных данных: целое тип выходных данных: целое, функция: x1*sin(x2) + x3*sin(x4)



Вы находитесь на странице вопроса "вычислите значение функции y=x^3-x^2+16x-43 для x изменяющегося в диапазоне от-4 до 4 включительно с шагом 0.5. Нужно написать на Паскале", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.