Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Дана символьная строка. Если какой-то символ встречается в ней более одного раза, первое вхождение этого символа оставить без измениния, второе заменить

10-11 класс

цифрой "2", третье-"3" и т.д.

Dianadebur 01 сент. 2014 г., 18:57:48 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Polinalala
01 сент. 2014 г., 20:51:57 (9 лет назад)

Program p1;
var
a:string;
i:integer;
begin
readln(a);
for i:=length(a) downto 2 do
begin
if a[i]=a[i-1]then delete(a,i,1);
end;
writeln(a);
end.
...........................................................................

Ввел: asdfsss

Результат: asdfs

Либо я не знаю либо нужно подумать. Но символу нельзя присвоить число ему можно присвоить только символ.

Ответить

Другие вопросы из категории

Задан адрес электронной почты в сети

Internet: [email protected] Каково имя
компьютера, на котором хранится почта?
а) ru;
б) [email protected];
в) mtu-net.

1. Довольно часто для чтения электронных книг используют специальные устройства, которые можно разделить по технологии воспроизведения информации на

экране. Выбери технологию, которая НЕ ИСПОЛЬЗУЕТСЯ в устройствах для чтения электронных книг:
1)E-Ink
2)TFT
3)SED
4)DLP

Паскаль.двухмерный массив.

В массиве B [1..10,1..3] содержатся данные о количестве сотрудников учреждения.Элементы первой строки обозначают номер отдела, элементы второй строки количество мужчин в нем,элементы третьей строки количество женщин в отделе.Сколько всего сотрудников в учреждении и кого больше: мужчин или женщин?

Читайте также

Помогите пожалуйста.

Нужно задать массив целых чисел. Вывести на экран только те значения элементов массива, которые встречаются в нем более одного раза, при этом каждое найденное значение должно быть распечатано столько раз, сколько оно встречается.

1. сколько символов содержит сообщение записанное с помощью 256 символьного алфавита если объем его составил 1/64 часть Мбайта?

2. Сообщение занимает 2 страницы по 60 строк и содержит 7200 байтов информации. Сколько символов в строке если при составлении этого сообщения использовали 256 символьный алфавит?
Срочно нужно помогите! и объяснение пожалуйста

Дана строка , в которой содержится осмысленное текстовое сообщение. Слова сообщения разделяются В заданном формате дд- целое число из диапазона от 1 до

31, мм - целое число из диапазона от 1 до 12, а гг - целое число из диапазона от 1 до 2020 (если какая-то часть формата нарушена, то данная подстрока в качестве даты не рассматривается.) Заменить каждую дату сообщения на дату следующего дня. Написать программу на Паскале. Сроооооооооооооочнооо. Пооожалуйста.....

10-11 класс информатика ответов нет
Cтроки. Паскаль. 1.Задано слово - последовательность произвольных символов. Сделать программу, в которой составляется слово перевертыш к данному

( символы записываются в обратной последовательности.)

2.Дана символьная строка. Слово - последовательность символов между пробелами, не содержащая пробелы внутри себя.составить программу, в которой выводились бы все слова, в которых есть заданный символ.



Вы находитесь на странице вопроса "Дана символьная строка. Если какой-то символ встречается в ней более одного раза, первое вхождение этого символа оставить без измениния, второе заменить", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.