Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

дана символьная строка заменить в ней последовательности символов расположенных между открывающими и закрывающими скобками на точки.предполагается,что

10-11 класс

внутри пары скобок вложенных нет

Relax1241 28 янв. 2015 г., 8:44:49 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ualbini
28 янв. 2015 г., 10:30:40 (9 лет назад)

program gt;
var a:string;
l,i,p:integer;
begin
readln(A);
l:=length(A);
p:=0;
for i:=2 to l do
begin
if(a[i-1]='(' )then p:=1;
if(a[i]=')' )then p:=0;
if(p=1)then a[i]:='.';
end;
writeln(a);
end.

Ответить

Другие вопросы из категории

Помогите написать программу по Информатике! Найти произведение двузначных нечетных чисел, кратных

13.

Нужно написать программу на цикле с предусловием, на Паскале.

Ввести с клавиатуры значение площади прямоугольного треугольника.( треугольник равнобедренный). Вывести на экран значение катетов, гипотенузы.

Использовать процедуру для получения результатов "Выходные переменные"

Поменять местами содержимое ячеек массива с максимальным и минимальными значениями.

Пожалуйста, помогите с информатикой:(

Читайте также

Cтроки. Паскаль. 1.Задано слово - последовательность произвольных символов. Сделать программу, в которой составляется слово перевертыш к данному

( символы записываются в обратной последовательности.)

2.Дана символьная строка. Слово - последовательность символов между пробелами, не содержащая пробелы внутри себя.составить программу, в которой выводились бы все слова, в которых есть заданный символ.

Задача F Четный палиндром

Подстрокой строки называется любая непустая последовательность символов в строке. Палиндромом называется строка, которая читается одинаково слева и справа.
У Азизхана есть строка S. Его интересует сколько есть подстрок четной длины у строки S, которые являются палиндромами. Одинаковые подстроки начинающие с разных позиций считаются разными.
Формат входных данных
Единственная строка входного файла содержит одну строку S состоящее из строчных букв английского алфавита (1 <= длина S <= 100000).
Формат выходных данных
Выведите ответ к задаче.

7) Для кодирования букв А, В, С, D используются четырехразрядные последовательные двоичные числа, начинающиеся с 1 (от 1001 до 1100 соответственно). Если

таким способом закодировать последовательность символов CADB и записать результат в шестнадцатеричном коде, то получится:
1) AF5216 2) 4CB816 3) F15D16 4) В9СА16



Вы находитесь на странице вопроса "дана символьная строка заменить в ней последовательности символов расположенных между открывающими и закрывающими скобками на точки.предполагается,что", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.