Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

ПОМОГИТЕ СОЗДАТЬ ДВУМЕРНЫЙ МАССИВ! Из случайных чисел от 1 до 30 создать массив размером M*N. Вывести на экран индексы элементов массива.

10-11 класс

Сонечка26 25 дек. 2016 г., 16:58:20 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Людми565
25 дек. 2016 г., 17:50:33 (7 лет назад)

Program Program1;
var
a:array [1..50,1..50] of integer;
m,n,i,j:integer;
begin
randomize;
write('Введите m: ');
readln(m);
write('Введите n: ');
readln(n);
for i:=1 to m do
begin
for j:=1 to n do
begin
a[i,j]:=random(30)+1;
write(a[ i, j ]:5);
end;
writeln;
end;
end.

Ответить

Другие вопросы из категории

литерные (символьные) (AnsiChar, WideChar, Char);

(Real48, Single, Double, Extended, Comp, Currency, Real).

что каждое из них значит в программировании?:

Читайте также

1. Задать двумерный массив (10х10) по формуле, так чтобы значения элементов совпадали с номерами столбцов в квадрате.

2. Задать двумерный массив (4х4) случайными значениями от 12 до 18 включительно. Вывести сумму значений элементов каждого столбца матрицы.
3. Задать двумерный массив (7х7) случайными значениями от 12 до 18 включительно. В каждом столбце матрицы найти количество элементов, значения которых меньше 14.
4. Задать двумерный массив (3х3) с клавиатуры, поменять значения элементов 1 столбца со вторым.
5. Найти минимальный элемент матрицы (5х5), заданной случайными значениями от 1 до 5 включительно, лежащие ниже главной диагонали.

1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.

определить число элементов массива, больших К. По заданному условию сформировать одномерный массив, вывести на печать и произвести операции по обрабо

тке полученных компонентов массива. Исходными данными являются одномерный массив, элементы которого задаются с помощью датчика случайных чисел от -50 до +50 и целое положительное число К

1)ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива

2) ввести с клавиатуры массив из n элементов вывести на экран максимальный четный элемент и минимальный нечетный элемент

Даны два целых числа А и В (А<В). Найти сумму всех целых чисел от А до В включительно Входные данные: ввести два целых числа А,В (1<=A,

B<=100).

Выходнфе данные: вывести сумму всех целых чисел от А до В включительно.

Можно, пожалуйста, с объяснением.



Вы находитесь на странице вопроса "ПОМОГИТЕ СОЗДАТЬ ДВУМЕРНЫЙ МАССИВ! Из случайных чисел от 1 до 30 создать массив размером M*N. Вывести на экран индексы элементов массива.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.