Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Ребят помогите, задали на дом задачу решить,а я уже себе голову сломал(((

10-11 класс

Marioooo 09 сент. 2014 г., 9:46:26 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Redterdrdtr
09 сент. 2014 г., 10:45:52 (9 лет назад)

uses crt;
var
{последовательность эл прогрессии будем записывать в массив b}
   c,b:array [1..50] of integer;
   n:integer;{размер массива}
   i,j:integer;
   k,d:integer;{счетчик эл в прогрессии и разность прогрессии}
   l,max:integer;
begin
  clrscr;
  write ('Razmer massiva:(N<50) ');readln(n);
  for i:=1 to n do begin
    write ('C[',i,'] = ');readln(c[i]);
  end;
   i:=1;
   j:=1;
   k:=0;
{запишем в массив b все прогрессии,содержащиеся в массиве c}
   while i<n do begin
    if (i<>1) and (c[i]=(c[i-1]+c[i+1])/2) then begin
     d:=c[i]-c[i-1];{вычисляем разность прогрессии}
     b[j]:=c[i-1];{записываем в массив 1ый эл прогрессии}
     inc(j);
     k:=k+1;
      repeat
       b[j]:=c[i];{пишем в массив след эл прогрессии}
       inc(i);
       inc(j);
       k:=k+1;
      until (i>n) or (c[i]<>c[i-1]+d);
    end;
    inc(i);
   end;
   for i:=1 to n do write (c[i],' ');
   writeln;
{Найдем в массиве b макс цепочку прогрессии}
   i:=2;
   l:=1;
   while i<k do begin
    d:=b[i]-b[i-1];
    if b[i+1]<>b[i]+d then i:=i+1 else
     while (b[i]=b[i-1]+d) and (i<=k) do begin
      l:=l+1;
      i:=i+1;
    end;
    if l>max then{если полученная цепочка больше пред, то}
     begin
      max:=l;{делаем её максимальной}
      j:=i-max;{записываем её левый индекс(начало цепочки}
    end;
    l:=1;
   end;
{вывод макс последовательности}
   write ('Max: ');
   for i:=j to max+j-1 do write (b[i],' ');
   writeln;
end.

Ответить

Другие вопросы из категории

Читайте также

Ребят, помогите! Тема: одномерные массивы. Две задачи:1) Написать прог

Ребят, помогите! Тема: одномерные массивы. Две задачи:

1) Написать программу, которая из заданного одномерного массива размерности N находит сумму только тех элементов, значения которых больше некоторого значения S.
S=5; Массив: 0,4 5,6 -2 10,1


2) При поступлении в ВУЗ абитуриенты, получившие "Двойку" на первом экзамене, ко второму не допускаются. В массиве A[N] записаны оценки экзаменующихся, полученных на первом экзамене. Подсчитать, сколько человек не допущено ко второму экзамену!

Заранее благодарю!

Помогите решить!!! Уже всю голову сломал, думая над этой задачей.

Если город представить в виде двумерного массива, то получается, что в каждом квартале (ячейке массива) может стоять либо Маша, либо камера (или несколько камер). Посчитать манхтэнское расстояние(сумма расстояний от Маши до всех камер) по формуле:
R= |x1-x2|+|y1-y2|.
Первоначальные координаты Маши (0,0).
Формат ввода:
Первая строка содержит N кол-во камер в городе и M шагов Маши. Вторая строка - координаты камер (х,y).
Для описания передвижения Маши с клавиатуры вводится символы U,D,R,L. Каждый из них означает:
U- увеличить координату у на 1.
D - уменьшить эту же координату.
L - уменьшить координату х.
R - увеличить координату х.
Выводить манхтэнское расстояние для каждого шага Маши.
Пример:
Ввод:___ Вывод:
1 3_______11
0 -10_____12
RUR _____13

Ребят помогите ПОЖАЛУЙСТА! не могу решить задачу по информатике. Найти все трехзначные числа, которые при увеличении на 1 делятся на 2, при увеличении

на 2 делятся на 3, при увеличении на 3 делятся на 4, при увеличении на 4 делятся на 5. Буду очень благодарна!!!!

Ребят, помогите с задачей. Буду признательна ,если подробно решение распишете.Первоначально сообщение на русском языке было записано в 16-битном

коде Unicode. При его перекодировке в 8-битную кодировку КОИ-8 информационное сообщение уменьшилось на 800 бит. Сколько символов в сообщении?



Вы находитесь на странице вопроса "Ребят помогите, задали на дом задачу решить,а я уже себе голову сломал(((", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.