Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Ввести n чисел. Определить сколько среди них положительных и кратных трём. Результат получить в переменной k.

10-11 класс

Исходные данные: n=5.

Ilchatovna 07 февр. 2017 г., 4:31:45 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sia205
07 февр. 2017 г., 6:09:40 (7 лет назад)

var
  k, n: byte;
  t: integer;

begin
  readln(n);
  for i: byte := 1 to n do
  begin
    readln(t);
    if ((t > 0) and (t mod 3 = 0)) then
      k += 1;
  end;
  writeln(k);
end.
---------------------------
алг 
нач
цел k, i, n, t
k := 0
ввод n
нц для i от 1 до n
ввод t
если ((t > 0) и (mod(t, 3) = 0)) то
k := k + 1
все
кц
вывод k
кон

+ 0 -
Nagoi01
07 февр. 2017 г., 8:36:37 (7 лет назад)

нужно составить алгоритм

Ответить

Другие вопросы из категории

Задачи для зачета по Турбо Паскалю! Очень важно!

1) Даны число A>0, числа x1,x2....
Необходимо вводить числа x1,x2.... , пока сумма модулей введенных чисел буде меньше A. Определить число введенных чисел.

2)Даны число n и векторы а=(а1,а2,....,аn) , b=(b1,b2,...,bn)
Найти координаты вектора с, равного сумме векторов a и b, если a1<b1, в противном случае равного разности векторов a и b. На экран выводить информацию о том, как получен вектор c.

3) Составить программу, которая данное слово запишет в обратном порядке.

Заранее спасибо!

1.2 и 1.3

Решите пожалуйста!!!!

запишите первые 20 чисел в 2 СС
Робота в паскале

Найти сумму целых положительных чисел , кратных 3 и меньше 30.

Читайте также

Циклические алгоритмы.СоставьтеЦиклические алгоритмы.Составьте блок- схему для решения следующих задач:

1) Вводятся 100 чисел.Определить сколько среди них положительных и сколько отрицательных.(Числа вводятся в одну переменную в цикле)
2) Алгоритм вычисления суммы квадратов десяти производных чисел, водимых с клавиатуры в процесс выполнения алгоритма
И НАПИШИТЕ ПРОГРАММУ ДЛЯ КАЖДОЙ ЗАДАЧИ

Напишите программу в Паскале:

Вводится 15 чисел. Определите сколько среди них целых чисел.



Вы находитесь на странице вопроса "Ввести n чисел. Определить сколько среди них положительных и кратных трём. Результат получить в переменной k.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.