Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

"У Удвоителя две команды, которым присвоены номера:

10-11 класс

1. Прибавь 1
2. умножь на 2
Первая-увеличивает число на экране на 1, вторая удваивает его.
Программа для удвоителя-это последовательность команд.
Сколько программ, которые число 2 преобразуют в число 22."
Так вот, в чем суть. Нужно написать программку для решения этой задачи. Я даже не знаю, с чего начать можно. Может вы сможете чем-то помочь?

Эвелина2002 07 окт. 2013 г., 16:34:09 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Coolkarpach
07 окт. 2013 г., 18:58:38 (10 лет назад)

2---->22    
1)   2*2=4
2)   4+1=5
3)   5*2=10
4)   10+1=11
5)   11*2=22
program chik;
var a,b,k:integer;
begin
a:=2;   b:=22;
k:=0;
while b>a do
begin
k:=k+1;
if(b mod a=0)then b:=b div a else b:=b-1;
if(b=2)then break;
end;
writeln(k);
end. 

Ответить

Другие вопросы из категории

1) Составить функцию, которая определяет наибольшее из трех чисел и привести пример ее использования. Пример: Введите три числа:

28 15 10

Наибольшее число: 28

2)Составить функцию, которая определяет сумму всех чисел от 1 до N и привести пример ее использования.

Пример:

Введите число:

100

Сумма = 500

Буду очень признателен за помощь.

Читайте также

У исполнителя Удвоитель две команды, которым присвоены номера: 1.прибавь 1, 2. умножь на 2. Первая из них увеличивает число на экране на 1, вторая

удваивает его. Программа для Удвоителя - это последовательность команд. сколько есть программ,которые число 3 преобразуют в число 24?

У исполнителя Удвоитель две команды, которые присвоены номера:

1. прибавь 1,
2. Умножь на 2.

Первая из них увеличивает число на экране на 1, вторая удваивает его.
Программа для Удвоителя - это последовательность команд.
Сколько есть программ, которые число 1 преобразуют в число 23?

Не нужен перебор, есть еще вроде метод решения!

Пожалуйста, подробное решение. Ответ я знаю, нужно только ПОДРОБНОЕ РЕШЕНИЕ.



Спасибо!

Исполнитель КАЛЬКУЛЯТОР имеет только две команды, которым присвоены номера:

Умножь на 2

Прибавь 1

Выполняя команду номер 1, КАЛЬКУЛЯТОР умножает число на экране на 2, а выполняя
команду номер 2, прибавляет к числу на экране 1. Напишите программу, содержащую не
более 5 команд, которая из числа 6 получает число 33. Укажите лишь номера команд.

Например, программа 12122 -это программа:
Умножь на 2

Прибавь 1

Умножь на 2
Прибавь 1
Прибавь 1

которая преобразует число 5 в число 24.

Исполнитель КВАДРАТОР имеет только две команды, которым присвоены номера:

1.Возведи в квадрат
2.Прибавь 1
Выполняя команду номер 1, КВАДРАТОР возводит число на экране в квадрат, а выполняя
команду номер 2, прибавляет к этому числу 1. Напишите программу, содержащую не
более 4 команд, которая из числа 2 получает число 36. Укажите лишь номера команд.
Например, программа 2122 – это программа:
Прибавь 1
Возведи в квадрат
Прибавь 1
Прибавь 1
которая преобразует число 1 в число 6.
1221

B 1. У исполнителя Калькулятор две команды, которым присвоены номера:

1. возведи в квадрат,
2. прибавь 1.

Пер¬вая из них возводит число на экране в квадрат, вторая увеличивает его на 1. Запишите порядок команд в программе, которая преобразует число 1 в число 10 и содержит не более 4 команд. Указывайте лишь номера команд. (Например, программа 2122 — это программ А


прибавь 1,

возведи в квадрат,
прибавь 1,
прибавь 1.

Эта программа преобразует число 3 в число 18.)



Вы находитесь на странице вопроса ""У Удвоителя две команды, которым присвоены номера:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.