Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Запишите полный текст программы.

5-9 класс

for i:= to n-1 do;
begin
imax:=i ;
for j:=i+1 to n do if a[ j]>a[imax] then imax:=j;
x:=a[i] ;
a[i];=a[imax];
a[imax]:=x ;

Sirotkinaekaterina 28 нояб. 2013 г., 16:23:10 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Eakhsanova
28 нояб. 2013 г., 18:08:41 (10 лет назад)

const
    n = 20;

var
    i, imax, j, x: integer;
    a: array[1..n]of integer;

begin
    for i := 1 to n do
        a[i] := random(100);
    for i := 1 to n - 1 do
    begin
        imax := i;
        for j := i + 1 to n do
            if a[j] > a[imax] then
                imax := j;
        x := a[i];
        a[i] := a[imax];
        a[imax] := x;
    end;
   
    for i := 1 to n do
      write(a[i],' ');
     
    writeln();
    writeln(imax);
   
end.

Ответить

Другие вопросы из категории

с 54 упр. 25 7.роман- поэма= стихотворение-... а)поэма б)рифма в)строфа г)жанр 9.север- юг= осадки... а)пустыня б)полюс в)дождь г)засуха 12.

слагаемое-сумма=множитель-... а)произведение б)частное в)разность г)умножение

Закончите определения: Информатика - это наука География - это наука Фонетика - это

раздел науки о

Ботаника - это раздел науки о

Имя существительное - это самостаятельная часть речи,

Глагол - это самостаятельная часть речи,

Земледельцы - это люди,

Животноводы - это люди,

Тяжёлая промышленность - это

Лёгкая промышленность - это

Заранее спасибо

Вознаграждение большое

Читайте также

. Составьте программу (полный текст программы) для решения следующей задачи. Введите с клавиатуры три числа: А, В, С. Если все они четные, то найдите и

выведите на экран их сумму. Если все они нечетные и A>B>C, то определите и выведите значения наибольшего и наименьшего из чисел. Иначе, выведите числа без изменения. Фрагмент программы: if (a mod 2 = 0) and (b mod 2 = 0) and (c mod 2 = 0) then begin S:=a+b+c; writeln('сумма равна ', S); end; if (a mod 2 <> 0) and (b mod 2 <> 0) and (c mod 2 <> 0) and (a>b) and (b>c) then begin writeln('наибольшее число ', A); writeln('наименьшее число ', C); end else writeln('a= ',a,' b= ', b, ' c= ',c);

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык
Бейсик
Паскаль
алг

нач

цел s, k

s := 0

нц для k от 7 до 11

s := s+11

кц

вывод s

кон


DIM k, s AS INTEGER

s = 0

FOR k = 7 TO 11

s = s+11

NEXT k

PRINT s
Var s,k: integer;

Begin

s := 0;

for k := 7 to 11 do

s := s+11;

writeln(s);

End.



Вы находитесь на странице вопроса "Запишите полный текст программы.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.