Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Паскаль.

5-9 класс

Написать функцию, находящую
максимальное из двух вещественных чисел и с её помощью определить максимальное
из 4-х вводимых с клавиатуры вещественных чисел.



алина107 08 сент. 2016 г., 6:41:44 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Erikashinohara
08 сент. 2016 г., 7:12:37 (7 лет назад)

Готово
function max(a1, a2:integer):integer;
begin
if a1>a2 then max:=a1 else max:=a2;
end;

var
a, b, c, d: integer;
begin
readln(a, b, c, d);
write(max(max(a, b), max(c, d)));
end.

Если есть какие-то вопросы или ещё нужна помощь, в ЛС.

Ответить

Другие вопросы из категории

Представьте в виде таблицы следующий текст (информация приведена за 2004 г.):



В Марий-Эл количество осадков в июле составило 79 мм. В Пермской области средняя температура в июле была +18 град. В Красноярском крае средняя температура в январе была – 18 град. В Московской области количество осадков в январе составило 45 мм. В Оренбургской области средняя температура в январе была –11 град. В Удмуртии количество осадков в июле составило 61 мм. В Марий-Эл количество осадков в январе составило 26 мм. В Оренбургской области средняя температура в июле была +21 град. В Красноярском крае количество осадков в июле составило 55 мм. В Оренбургской области количество осадков в январе составило 35 мм. В Пермской области количество осадков в январе составило 52 мм. В Марий-Эл средняя температура в январе была –10 град. В Оренбургской области количество осадков в июле составило 89 мм. В Московской области средняя температура в июле была +20 град. В Удмуртии средняя температура в январе была –13 град. В Красноярском крае количество осадков в январе составило 36 мм. В Удмуртии средняя температура в июле была +19 град. В Московской области количество осадков в июле составило 66 мм. В Удмуртии количество осадков в январе составило 41 мм. В Пермской области количество осадков в июле составило 45 мм. В Марий-Эл средняя температура в июле была +20 град. В Красноярском крае средняя температура в июле была +17 град. В Пермской области средняя температура в январе была –14 град. В Московской области средняя температура в январе была –8 град.

Паскаль АВС

составить программу, которая создает массив случайных чисел размером (N x M), выводит его на экран и вычисляет произведение ненулевых элементов массива.

Читайте также

Помогите решить задачки на паскале я совсем не разбираюсь в этом!!! 1)Дана таблица со значениями среднемесячных температур в течение года. Составить

программу на Паскале, в которой вычисляются четыре величины: средние температуры зимних месяцев, весенних месяцев, летних и осенних. 2)Вы посетили магазин и купили 10 видов товара. В таблицу T [1..10] записали количество купленного товара каждого вида. В таблицу C [1..10] записали цену единицы каждого вида товара соответственно. Составить программу на Паскале вычисления общей стоимости всех покупок.

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Даны натуральное число n и вещественные числа a1, a2, ..., an. Определить среднее арифметическое вещественных чисел...

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Паскаль, в его первоначальном виде, представляет собою чисто процедурный язык.

Простейшая программа на Паскале будет выглядеть следующим образом:
program upr;
begin
writeln ( ? ); {оператор вывода строки}
end.
Определи, какая фраза пропущена на месте вопросительного знака?
’Hello, World!’
“Lorem ipsum”
Just Another Perl Hacker

Найти алгоритм минимума из 3х целых чисел на паскале+ составить блок -схему.

ПОЖАЛУЙСТА,ХОТЯ БЫ НА ПАСКАЛЕ СОСТАВЬТЕ!

ПРОГРАММИРОВАНИЕ,ПАСКАЛЬ.РЕБЯТА,УМОЛЯЮ,ПОМОГИТЕ.

Задали написать программу на язвке паскаль:вычислить и вывести на экран 8 первых элементов ряда если каждый элемент задан формулой а1= i/sin*i



Вы находитесь на странице вопроса "Паскаль.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.