Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

составить линейную программу, которая печатает true, если точка

10-11 класс

с координатами (х, у) принадлежит закрашенной области, и false — в
противном случае:

укярфт222 30 дек. 2013 г., 4:37:08 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Renesmaa
30 дек. 2013 г., 5:44:51 (10 лет назад)

var
  x, y: real;

begin
  Write('Введите через пробел координаты точки (x,y): ');
  Readln(x, y);
  Write((y >= 0) and (y <= 4 - abs(x)))
end.

Тестовое решение:

Введите через пробел координаты точки (x,y): 1 3.1
False

Введите через пробел координаты точки (x,y): -1 2.9
True



+ 0 -
Lenarazueva
30 дек. 2013 г., 6:18:47 (10 лет назад)

Комментарий удален

+ 0 -
Alinka270799
30 дек. 2013 г., 8:24:20 (10 лет назад)

Потому что True-это правда, а False-это ложь.

+ 0 -
Niknovikov03
30 дек. 2013 г., 10:57:15 (10 лет назад)

Программу составить на Паскаль?

+ 0 -
Vykvrer
30 дек. 2013 г., 12:57:13 (10 лет назад)

да

Ответить

Другие вопросы из категории

Читайте также

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.



Вы находитесь на странице вопроса "составить линейную программу, которая печатает true, если точка", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.