Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

составить программу которая печатает true если точка с координатами x,y принадлежит закрашенной области.

10-11 класс

Eliz131002 30 сент. 2013 г., 11:17:25 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Max7171
30 сент. 2013 г., 14:11:34 (10 лет назад)

var x,y:integer;
 b,b1:boolean;
begin
writeln('Введите x');
readln(x);
writeln('Введите y');
readln(y);
if(x<=2)  then
if(x>=-2) then
if(y>=0) then
if(y<=4) then b:=true
else  b:=false;
if(x<=5)  then
if(x>=-4) then
if(y>=0) then
if(y<=-3) then    b1:=true
else b1:=false;
writeln(b or b1);
readln;
end.

Ответить

Другие вопросы из категории

дана строка. Каждую точку замените многоточием (т.е тремя точками). В чем беда? или совсем не правильно?

var str : string;
q:integer;
k:string;
begin
writeln ('введите строку');
readln (str);k:='..';
q:=pos('.', str );
while q<>0 do
begin
insert (str,k, q );
q:=pos('.', str );
end;
writeln (str);
end.

Читайте также

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.

составить линейную программу, которая печатает true, если точка

с координатами (х, у) принадлежит закрашенной области, и false — в
противном случае:



Вы находитесь на странице вопроса "составить программу которая печатает true если точка с координатами x,y принадлежит закрашенной области.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.