Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

ПОМОГИТЕ ПОЖАЛУЙСТА,ДАЮ 30 БАЛЛОВ!

5-9 класс

Составьте программу ,которая формирует массив ,содержащий 8 случайных целых чисел, принадлежащих промежутку [0;5] ,и преобразует элементы массива по следующему правилу: чётное число умножает на 5 ,а от нечётного отнимает 2.

Colder43 05 марта 2017 г., 23:05:22 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Losdo
06 марта 2017 г., 1:56:50 (7 лет назад)

var
a:array[1..8] of integer;
i:integer;
begin
randomize;
for i:=1 to 8 do
begin 
a[i]:=random(6); 
  if a[i] mod 2 = 0 then a[i]:=a[i]*5
  else a[i]:=a[i]-2;
  write(a[i],' ');
 end;
end.

Надеюсь на "Лучший ответ"

+ 0 -
Mrdaniil02
06 марта 2017 г., 3:57:35 (7 лет назад)

uses crt;
var a:array[1..8] of integer;
    x:integer;
begin
     randomize;
     for x:=1 to 8 do
     begin
          a[x]:=random(6);
          writeln('a[',x,']:',a[x]);
     end;
     writeln;
     for x:=1 to 8 do
     begin
          if a[x] mod 2=0 then a[x]:=a[x]*5
             else a[x]:=a[x]-2;
          writeln('a[',x,']:',a[x]);
     end;
end.

Ответить

Другие вопросы из категории

Составить блок-схему.Использую циклическую форму организации действий,запишите следующие алгоритм выполнения домашнего задания по переводу текста с

иностранного язык:Наити первое предложение.Перевести его.Записать перевод.Наити следующие предложение.Перевести его.

Читайте также

ПОМОГИТЕ ПОЖАЛУЙСТА,ДАЮ 30 БАЛЛОВ!

Составьте программу ,которая формирует массив ,содержащий 12 случайных вещественных чисел ,принадлежащих промежутку от [-10;30] , и подсчитывает произведение всех отрицательных чисел. Вывод в столбец с тремя десятичными знаками.

Помогите,пожалуйста с тестом по информатике! Это срочно! Даю 30 баллов!

1.Примером документальной базы данных является база данных,содержащая:
а)законодательные акты
б)Сведения о кадровом составе учреждения
в)Сведения о финансовом состоянии учреждения
2.База данных - это...
3.Примером иерархической базы данных является
а)Страница классного журнала
б)Каталог файлов,хранимых на диске
в)Расписание поездов
г)Электронная таблица
4.Наиболее точным аналогом реляционной базы данных может служить:
а) Неупорядоченное множество данных
б) Вектор
в) Генеалогическое древо
г) Двумерная таблица
5. Поля реляционной базы данных
а) Именуются пользователем произвольно с определенными ограничениями
б) Автоматически нумеруются
в) Именуются по правилам,специфичным для каждой конкретной СУБД
г) Нумеруются по правилам,специфичным для каждой конкретной СУБД
6.Структура реляционной базы данных меняется при удалении:
а) Одного из полей
б) Одной записи
в) Нескольких записей
г) Всех записей
7.В записи реляционной базы данных может содержаться:
а) Неоднородная информация(данные разных типов)
б) Исключительно однородная информация(данные только одного типа)
в) Только текстовая информация
г) Исключительно числовая информация
8. Значение выражения 0,7-3>2 относится к следующему типу данных:
а) Числовому
б) Логическому
в) Строковому
г) Целому
9. Система управления базами данных(СУБД) - это...
10. Модель отражает:
а) Все существующие признаки объекта
б) Некоторые из всех существующих
в) Существенные признаки в соответствии с целью моделирования
г) Некоторые существенные признаки объекта
д) Все существенные признаки
11. При описании отношений между элементами системы удобнее всего использовать информационную модель следующего типа:
а) Текстовую
б) Математическую
в) Структурную
г) Табличную
д) Графическую
12. Понятие модели имеет смысл при наличии:
а) Моделирующего субъекта и моделируемого объекта
б) Цели моделирования и моделируемого объекта
в) Моделирующего субъекта;цели моделирования и моделируемого объекта
г) Цели моделирования и двух различных объектов
д) Желания сохранить информацию об объекте
13. Рисунки,карты,чертежи,диаграммы,схемы,графики представляют собой модели следующего вида:
а) Табличные информационные
б) Математические модели
в) Натурные
г) Графические информационные
д) Иерархические информационные
14. Суть основного тезиса формализации состоит в принципиальной возможности:
а) Представления информации на материальном носителе
б) Передачи информации от одного объекта к другому
в) Обработка информации человеком
г) Хранение информации в памяти компьютера
д) Разделение объекта и его обозначения

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!



Вы находитесь на странице вопроса "ПОМОГИТЕ ПОЖАЛУЙСТА,ДАЮ 30 БАЛЛОВ!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.