Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите найти ошибку в программе!! Срочно! (Delphi)

5-9 класс

иззы 13 февр. 2015 г., 21:31:47 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Enyara
13 февр. 2015 г., 23:46:47 (9 лет назад)

есть на компе программа что-бы это начертить?если да то начерти и нажми"шаг"и считай по цифрам(1,2,3...и т.д.)пока-что не найдёшь ошибку...так гораздо легче !!

Ответить

Другие вопросы из категории

1. В

цветовой модели RGB для кодирования одного пикселя используется 3 байта.
Фотографию размером 2048×1536 пикселей сохранили в виде несжатого файла с
использованием RGB-кодирования. Определите размер файла в Мб

Записать в развернутой форме следующие числа 1. 12345,6789 10 2. 1000110,1101 2 3. 123,706 8 4. 10212 3 5. 12A5B0F,5E 16 6. 1143,121 5 7. 555,55 6 8.

1203,1 4
Записать в свернутой форме 1. 4·10 3 +0·10 2 +2·10 1 +9·10 0 +8·10 -1 2. 1·2 5 +1·2 4 +1·2 3 +0·2 2 + 1·2 1 +1·2 0 +1·2 -1 +1·2 -2 3. 6·16 3 +10·16 2 +0·16 1 +12·16 0 +1·16 -1 4. 1·5 4 +3·5 3 + 0 · 5 2+ 4·5 1 +0 · 5 0+ 0 · 5 -1+ 1·5 -2

Читайте также

Помогите найти ошибку в программе (Массив)

Program Ah;
uses crt;
var A:array[1..15] of integer;
i,k,n:integer;
begin
clrscr;
for i:=1 to 18 do begin
writeln('A[',i,']=');
read(A[i]);
end;
writeln('Введите число');
read(n);
k:=0;
for i:=1 to 15 do begin
if a[i]>n then
k:=k+1;
writeln('k=',k);
readkey;
end.
(В последней строке выдает "Ошибка, ожидается точка с запятой")

Очень нужна помощь. Помогите найти ошибки - Паскаль.

Условие: Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами.

Не совсем то выводит, и модуль может как-то через abs надо.

program proizvedenie;
var q,z,w,i,n,i1,i2:integer;
a:array[1..1000] of real;
amin,amax,pr:real;
begin
assign (input,'input.txt');
assign (output,'output.txt');
reset (input);
rewrite (output);
readln(n);
for i:=1 to n do read (a[i]);
amin:=a[1];
for i:=1 to n do
begin
if a[i]<amin then
begin
amin:=a[i];
i1:=i;
end;
end;
amax:=a[1];
for i:=1 to n do
begin
if a[i] > amax then
amax:=a[i];
i2:=i;
end;
if i2>i1 then begin
q:=i1;
w:=i2;
end
else begin
q:=i2;
w:=i1;
end;
if (w-q)>1 then begin
pr:=1;
for z:=q to w do
pr:=pr*a[z];
end
else write (0);
close (input);
close (output);
end.

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!



Вы находитесь на странице вопроса "Помогите найти ошибку в программе!! Срочно! (Delphi)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.