Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Помогите найти ошибку в программе (Массив)

5-9 класс

Program Ah;
uses crt;
var A:array[1..15] of integer;
i,k,n:integer;
begin
clrscr;
for i:=1 to 18 do begin
writeln('A[',i,']=');
read(A[i]);
end;
writeln('Введите число');
read(n);
k:=0;
for i:=1 to 15 do begin
if a[i]>n then
k:=k+1;
writeln('k=',k);
readkey;
end.
(В последней строке выдает "Ошибка, ожидается точка с запятой")

Ksyshka68 09 июня 2014 г., 3:27:07 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kotelnikova95
09 июня 2014 г., 3:57:34 (9 лет назад)

for i:=1 to 15 do begin
if a[i]>n then
k:=k+1; 
end; 
Вот тут не хватает end

Ответить

Другие вопросы из категории

Семья ночью подошла к мосту. Папа

может перейти его за 1 минуту, мамаза 2, малышза 5, а бабушказа 10 минут. У них есть один фонарик. Мост выдерживает только двоих. вот с такой штукой !!!!
плиззз

Определить стоимость покупки с учетом скидки . Скидка в 10% предоставляется если сумма покупки больше 1000 рублей. Входные данные S-стоимость покупки.

ВХОДНЫЕ ДАННЫЕ S- стоимость покупки с учетом скидки( если она предоставляется)

Помогите начертить две звезды в Чертежнике в программе ,,Кумир,,

напишите пожалуйста координаты

ПОМОГИТЕ РЕШИТЬ

вот несколько примеров: 2021₁₀=MMXX1
583₁₀=DXXIII

Решите, пожалуйста, наподобие верхних вот эти примеры:
321₁₀=
и наоборот в цифры:
DXCI=
CMXLVI=
CDLXIX=

1) Начертить получившийся массив и обозначить его индексы:

For i:=-10 to -3 do
A [ i ] := 2*I;
2) Начертить получившийся массив и обозначить его индексы:
K:=1;
For i:=-10 to -3 do
begin
A [ i ] : 2*I+k;
K:=k*2
End;

Читайте также

Очень нужна помощь. Помогите найти ошибки - Паскаль.

Условие: Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами.

Не совсем то выводит, и модуль может как-то через abs надо.

program proizvedenie;
var q,z,w,i,n,i1,i2:integer;
a:array[1..1000] of real;
amin,amax,pr:real;
begin
assign (input,'input.txt');
assign (output,'output.txt');
reset (input);
rewrite (output);
readln(n);
for i:=1 to n do read (a[i]);
amin:=a[1];
for i:=1 to n do
begin
if a[i]<amin then
begin
amin:=a[i];
i1:=i;
end;
end;
amax:=a[1];
for i:=1 to n do
begin
if a[i] > amax then
amax:=a[i];
i2:=i;
end;
if i2>i1 then begin
q:=i1;
w:=i2;
end
else begin
q:=i2;
w:=i1;
end;
if (w-q)>1 then begin
pr:=1;
for z:=q to w do
pr:=pr*a[z];
end
else write (0);
close (input);
close (output);
end.

Помогите,пожалуйста,написать программу по информатике.Вот такое условие:

Составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет:
1). сумму чисел, не превышающих 10;
2). сумму чисел,кратных 3. Помогите пожалуйста,написать эту программу на PaskalABC.

написать программу которая вычисляет оптимальный вес пользователя сравнивая его с реальными выдаёт рекомендации о необходимости поправиться или

похудеть.по формуле рост минус 100...

написать то легко но учитель сказал что б говорилось на сколько худеть или поправиться надо ...(( ну ни как не могу додуматься(( помогите (( вот сама написаная программа

Program Zadacha1;
Var ves, rost, optVes:integer;
Begin
write('введите массу тела');
read(ves);
write('введите рост в см');
read(rost);
optVes:=rost-100;
if ves>optVes then write('вам необходимо похудеть' );
if ves<optVes then write('вам необходимо поправиться');
if ves=optVes then write ('ваш вес оптимальный')
End.



Вы находитесь на странице вопроса "Помогите найти ошибку в программе (Массив)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.