Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

ТЕМА: МАССИВЫ

10-11 класс

помогите плиз!

Написать программу расчета среднего арифметического отрицательных элементов в одномерном массиве. Заменить минимальный элемент в одномерном массиве на полученное среднее арифметическое.

катюшасупер 27 июля 2013 г., 14:01:17 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ulianachizhova
27 июля 2013 г., 15:42:46 (10 лет назад)

var
  i,n:integer;
  s,min:real;a:array[1..10]of real;
begin
writeln('Исходный массив:');
for i:=1 to 10 do
  begin
  a[i]:=random(-10,10);
  write(a[i],' ');
  if a[i]<0 then
     begin
     s:=s+a[i];
     n:=n+1;
     end;
  if a[i]<min then min:=a[i];
  end;
writeln;
s:=s/n;
for i:=1 to 10 do  if a[i]=min then a[i]:=s;
writeln('Среднее отрицательных:',s);
writeln('Измененный массив:');
for i:=1 to 10 do  write(a[i],' ');
end.

Ответить

Другие вопросы из категории

1.
4. Подсчитайте за один проход, сколько его элементов равны максимальному элементу.

На вход программе сначала подается значение n<=100 – количество элементов в массиве. В следующей строке входных данных расположены сами элементы массива – целые числа, по модулю не превосходящие 30000. Выдайте количество искомых элементов массива.

Помогите решить срочно
пожалуйста, скорее....

составить программу которая найдет номер максимального элемента (массив из 10 случайных чисел)

Читайте также

Тема "Массивы" 10 класс

Друзья я ноль в информатике, помогите пожалуйста.
Буду очень благодарна. :)

Ребят, помогите! Тема: одномерные массивы. Две задачи:1) Написать прог

Ребят, помогите! Тема: одномерные массивы. Две задачи:

1) Написать программу, которая из заданного одномерного массива размерности N находит сумму только тех элементов, значения которых больше некоторого значения S.
S=5; Массив: 0,4 5,6 -2 10,1


2) При поступлении в ВУЗ абитуриенты, получившие "Двойку" на первом экзамене, ко второму не допускаются. В массиве A[N] записаны оценки экзаменующихся, полученных на первом экзамене. Подсчитать, сколько человек не допущено ко второму экзамену!

Заранее благодарю!

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.



Вы находитесь на странице вопроса "ТЕМА: МАССИВЫ", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.