Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Ввести натуральное число N (не больше 2147483647). Определите сколько в нем знаков, вычислить сумму цтфр сисла и определить старшую цифру числа.

5-9 класс

Rusikbakirov 31 дек. 2013 г., 5:02:08 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ArikaZyka
31 дек. 2013 г., 6:57:08 (10 лет назад)

var  a, k, m, sum, n: longint;
begin
  writeln('Введите число');
  readln(a);
  sum := 0; m := a; n := a mod 10;
  while a <> 0 do
   begin
    sum := sum + a mod 10;
    if n < a mod 10 then n := a mod 10;
    a := a div 10;
    k := k + 1;
  end;
  writeln('В числе ', m, ' - ', k, ' цифр. Их сумма равна - ', sum, '. Старшая цифра числа - ', n'.');
  readln
end.

Ответить

Другие вопросы из категории

Помогите пожалуйста решить задачу по информатике:

Книга, набранная с помощью компьютера, содержит 5 страниц по 30 строк. Объем всего текста - 1500 байтов. Сколько символов в строке?

Помогите пожалуйста решить задания:

1) Преобразуйте двоичное число в восьмеричное:1010100
2)Преобразуйте двоичное число в десятичное:100010
3)Преобразуйте двоичное число в шестнадцатеричное:1110001000
4)Преобразуйте восьмеричное число в двоичное:67
5)Преобразуйте восьмеричное число в десятичное:207
6)Преобразуйте восьмеричное число в шестнадцатеричное: 2246
7)Преобразуйте десятичное число в двоичное:404
8)Преобразуйте десятичное число в восьмеричное:283
9)Преобразуйте десятичное число в шестнадцатеричное:1001
10)Преобразуйте шестнадцатеричное число в двоичное:5D
11)Преобразуйте шестнадцатеричное число в восьмеричное:4C
12)Преобразуйте шестнадцатеричное число в десятичное: 35B

Дано двузначное число. определить одинаковы ли его числа.

(Язык Паскаль)

Читайте также

Программу надо написать в PascalABC, с использованием команд repeat и until. Ввести натуральное число и определить, какие цифры встречаются несколько раз

(с защитой от неверного ввода) или Ввести натуральное число и определить, верно ли, что сумма его цифр равна 10 (с защитой от неверного ввода).

PASCAL ABC Составить программу, которая определяет подходит кандидат на работу или нет. Возраст:не больше 50, не меньше 17 Стаж:не

менее 3-х лет

Задача2
Даны три числа, определить сколько чётных
Задача3
Является ли 4-х значное число палендромом

Играют двое . Первый игрок называет любое число но не выше 10 . Второй прибовляет к названаму числу число не выше 10 и сообщает сумму . 1-й к этой сумме

он прибовляет число но не меньше 10 и т.д. до тех пор , пока ок. Суммой не окажется 100.Выигравает тот , кто первым достигает 100. Как должен действовать первый игрок , чтобы выйграть .



Вы находитесь на странице вопроса "Ввести натуральное число N (не больше 2147483647). Определите сколько в нем знаков, вычислить сумму цтфр сисла и определить старшую цифру числа.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.