Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

написать программу которая в двух. массиве найдет А)произведение целых чисел по строкам б) вычислит сумму элементов главной и обратной диагонали

5-9 класс

Умоляю ребята

Luiza7991 30 июля 2016 г., 20:56:46 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mtsmen
30 июля 2016 г., 23:44:24 (7 лет назад)

var i, j, a, b:integer;
      s:array [1..10000,1..10000] of real;
      pr:array [1..10000] of real;
      k:array [1..10000] of integer;
      sum1, sum2:real;
begin
   writeln ('Введите количество столбцов');
   read (a);
   for i:=1 to a do pr[i]:=1;
   for i:=1 to a do
       for j:=1 to a do
         begin
         read (s[i,j]);
         if int(s[i,j])=s[i,j] then
             begin
            inc(k[i]);
            pr[i]:=pr[i]*int(s[i,j]);
            end;
         end;
   for i:=1 to a do
       if k[i]>0 then writeln(pr[i]:1:0) else writeln ('0');
   for i:=1 to a do
       begin
      sum1:=sum1+s[i,i];
      sum2:=sum2+s[a-i+1,a-i+1];
      end;
   writeln (sum1:0:5,' ',sum2:0:5);
end.
P.S. Надеюсь на лучший ответ)
P.S.S. Насчет диагоналей, я сделал так, что кол-во столбцов и строк одинаково, ибо не представляю сумму диагоналей у прямоугольника без дополнительных условий.

Ответить

Другие вопросы из категории

Заполните таблицу.

Вид информации Чувство. Орган
зрительная
звуковая
вкусовая
обонятельная
осязательная

Помогите пожалуйста с информатикой 7 класс (Паскаль, Условный оператор)

Задача : Запрашивается стоимость книги и внесённая оплата, если оплата совпадает со стоимостью, то пишется "спасибо". Если оплата меньше, то пишется "добавьте денег".
Если оплата больше стоимости то пишется "возьмите сдачу" и сумма сдачи.

Читайте также

1) составить программу , которая вычисляет суммы элементов столбцов двумерного массива и записывает их в одномерный

2-ая Составить программу , которая в двумерном массиве случайных чисел элементы всех четных строк делает нулевыми
язык паскаль

1)составьте программу,которая заполняет массив a[1..10] случаынми целыми числами в диапазоне от 0 до 10 и находит минимальный элемент массива среди

элементов с нечётными индексами

2)составьте программу,которая заполняет массив a[1..10]случайными целыми числами в диапазоне от 0 до 10,находит максимальный элемент массива,а затем вычисляет,сколько раз он встречается в массиве

Помогите плиз срочно 1)Написать программу,которая спрашивает"Который час?" и,в зависимости от введенного времени,выводит приветствие:"Доброе

утро","Добрый день","Добрый вечер", "Спокойной ночи". 2)Написать программу,которая определяет,принадлежит ли точка с координатами (x,y)Заштрихованной области,ограниченной точками(x1,y1)(x2,y2).

№1 Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и вычисляет произведение массива с четными

значениями. №2 Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 до 10 и вычисляет среднее арифметическое элементов массива. №3 Такое же как и №2, только ...элементов массива с четными значениями.



Вы находитесь на странице вопроса "написать программу которая в двух. массиве найдет А)произведение целых чисел по строкам б) вычислит сумму элементов главной и обратной диагонали", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.