Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите, пожалуйста. Написать программу, которая находит среднее арифметическое чисел 1, 2, 4, 8, 16 и т.д. Количество чисел вводится с

5-9 класс

клавиатуры.

Язык-Паскаль.

ВИА0626 06 дек. 2013 г., 4:28:56 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Gwen
06 дек. 2013 г., 6:02:38 (10 лет назад)

var
  sum, n, i: integer;
begin
  writeln('Введите кол-во чисел: ');
  readln(n);
  writeln('Числа: ');
  sum := 1;
  while i <> n do
   begin
    write(sum, ' ');
    sum := sum * 2;
    inc(i);
  end;
writeln;
writeln('Среднее арифметическое: ', sum / n);
end.

Ответить

Другие вопросы из категории

Данные числа c и d являются соотвественно квадратом и кубом числа "A"

нужно составить программу , печатающее значение true, если указанное выражение является истинным, и fase в противном случае
Главное программу! Будьте добры

Cколько здесь нулей? 000000000000000000000

000000000000000000000000000000000000000000000000000000000000
000000000000000000000000000000000000000000000000000000000000
000000000000000000000000000000000000000000000000000000000000
000000000000000000000000000000000000000000000

на пляже по каждым зонтом должно размещаться по два лежака. туристы переставили лежаки так, как показано на рисунке. какая команда пропущена(замена знаком

вопроса) в алгоритме расстановки лежаков к первоначальному виду:по два каждым зонтом?

Читайте также

Напишите программу, которая в последовательности целых чисел находит среднее арифметическое чисел, кратных 9, или сообщает, что таких чисел нет.

Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не является членом последовательности). Количество чисел не превышает 100. Введённые числа по модулю не превышают 300. Программа должна вывести среднее арифметическое чисел, кратных 9, или вывести NO, если таких чисел в последовательности нет.

Помогите,пожалуйста,написать программу по информатике.Вот такое условие:

Составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет:
1). сумму чисел, не превышающих 10;
2). сумму чисел,кратных 3. Помогите пожалуйста,написать эту программу на PaskalABC.

Пожалуйста помогите решить желательно все или хотя бы одну (P.S. программа для программы Turbo Pascal) 1.Написать программу, которая предлагает

ввести 3 значное число и находит сумму его цифр.

2. Написать программу, которая предлагает ввести 3 значное число и меняет порядок цифр наоборот. (123- 321)

3.Написать программу, которая предлагает ввести три числа с клавиатуры, находит их сумму, произведение и среднее арифметическое.

Помогите пожалуйста написать 2 программы

1)Написать программу которая меняет местами числа a и b(линейная и оператор присваивания)
2)Программа проверки существования треугольника по его 3 сторонам
Напишите пожалуйста***



Вы находитесь на странице вопроса "Помогите, пожалуйста. Написать программу, которая находит среднее арифметическое чисел 1, 2, 4, 8, 16 и т.д. Количество чисел вводится с", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.