Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

составить программу вычисления значения функций в зависимости от интервала у=1+3х, при х<-2 1+xв квадрате, при -2<_x<_2 (x+1), при x>2

5-9 класс

Olgaart2001 01 марта 2015 г., 10:29:40 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Munik
01 марта 2015 г., 11:51:01 (9 лет назад)

var x,y:real;
begin
writeln ('Введите x');
readln (x);
if (x<-2) then y:=1+3*x;
if (x>=-2) and (x<=2) then y:=sqr(1+x); //по условию -2<_x<_2 я подумал, что _ значит =, если нет - удали равно здесь (x>=-2) and (x<=2)
if (x>2) then y:=x+1;
writeln ('Значение функции = ',y);
end.

Ответить

Читайте также

Помогите, пожалуйста, решить самостоятельную:1.Составьте блок-схему и программу вычисления значения функции

(картинка дана ниже)

2.Составьте программу, определяющую, является ли данное число делителем числа 3.

3.Составьте программу, заменяющую меньшее из двух данных чисел суммой, а большее - произведением этих чисел.

Заранее спасибо.

1) Составьте программу вычисления в массиве A(N) суммы всех чисел, кратных 3. 2) Составьте программу вычисления в массиве B(8) суммы отрицательных

элементов. 3) Составьте программу вычисления среднего арифметического элементов массива. Пожалуйста.. очень надо!

ребят, помогите пожалуйста, ну ооочень нужно, от этого зависит аттестуют меня или нет, заданий правда много, и пожалуйста, не пишите херню либо очень

мало
эти задания нужно сделать циклами while и for, т е чтобы получилось 12 программ

1. Составьте программу вычисления значения функции: y=7x^2+1/x^2-16
2. Составьте блок-схему алгоритма и программу расположения четырех чисел в порядке возрастания.
3*. Составьте программу, определяющую вид треугольника по трем его сторонам A, B, C.

4. Составьте блок-схему алгоритма и программу вывода на экран всех трехзначных чисел, кратных 7.
5. Составьте блок-схему алгоритма и программу вычисления суммы всех трехзначных чисел, кратных 13.
6*. Составьте программу вывода на экран таблицы степеней 2ⁿ, где 0 ≤ n ≤ 10.

я вас просто умоляю, напишите, пожалуйста



Вы находитесь на странице вопроса "составить программу вычисления значения функций в зависимости от интервала у=1+3х, при х&lt;-2 1+xв квадрате, при -2&lt;_x&lt;_2 (x+1), при x&gt;2", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.