Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Заполнить массив случайными числами в интервале [-1,1] и подсчитать количество нулевых элементов

5-9 класс

Lolca123 12 янв. 2015 г., 15:32:39 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Аришка777
12 янв. 2015 г., 17:35:01 (9 лет назад)

var
  i,a:integer;
  m:array[1..10] of integer;
begin
  randomize;
  for i:=1 to 10 do
  begin
    m[i]:=random(2)-1;
    if m[i]=0 then a:=a+1;
  end;
 
  writeln(a);
end.

+ 0 -
маммеева
12 янв. 2015 г., 20:08:55 (9 лет назад)

var
r,i,a:integer;
m:array[1..10];
begin
for i:=1 to length(m) do
begin
randomize;
r:=random(2)-1;
m[i]:=r;
end;
for i:=1 to length(m) do
begin
if m[i]=0 then a:=a+1;
end;
writeln(a);
end.

Ответить

Читайте также

С помощью Паскаля:

1.Заполните массив случайными числами в интервале [0;100] и подсчитайте отдельно среднее значение всех элементов,которые меньше 50, и среднее значение всех элементов,которые больше или равны 50.
2.Заполнить массив случайными числами в интервале [0;5]. Определить, есть ли в нем элементы с одинаковыми значениями,стоящие рядом.
3. Заполнить массив случайными числами и выполнить реверс отдельно в первой половине и во второй половине.

1.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество.

2.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50. Заменить все четные элементы на их квадраты, а нечетные удвоить.

Помогите,пожалуйста. Надобно написать программу в паскале.

Заполнить массив случайными числами в интервале от -10 до 10 и выполнить инверсию отдельно для 1 и 2 части.
Пример:
1 -2 6 -8 -3 | 5 -7 1 0 -4
-3 -8 6 -2 1 | -4 0 1 -7 5



Вы находитесь на странице вопроса "Заполнить массив случайными числами в интервале [-1,1] и подсчитать количество нулевых элементов", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.