Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

с клавиатуры вводятся натуральное число n и вещественное число x. вычислить сумму (-1)^n*(2x)^2n/(2n+1)!

10-11 класс

Annatkachenko 02 окт. 2013 г., 18:30:11 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Bykovanatal
02 окт. 2013 г., 19:06:44 (10 лет назад)

program proga_1;
var  x: real;  n: integer;
function func(n: integer; x: real): real;var  i: integer;  i1, i2, i3: real; 
 
//функция вычисления степени
 function power(n: integer; x: real): real; 
var  i: integer; res: real;
begin res := x; for i := 1 to n - 1 do res := res * x;
power := res;
 end;
 //фукция вычисления факториала 
 function factorial(x: integer): integer;
 var    i, res: integer;
begin for i := 1 to x do inc(res, i);
 factorial := res;
 end;
begin
  if n mod 2 = 0 then i1 := 1 else i1 := -1; //определяем число -1 степени n 
i2 := power(2 * n, 2 * x);
i3 := factorial(2 * n + 1);
func := (i1 * i2) / i3;end;
begin 
write('Введите n: '); readln(n); 
write('Введите x: '); readln(x); 
 writeln('Сумма равна: ', func(n, x));  
end.

Ответить

Другие вопросы из категории

решите задание пожалуйста)
№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от -100 до 100. Напишите программу, которая позволит

подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива. №2. Дан массив из 40 элементов. Каждый элемент может принимать целочисленные значения от 0 до 200. Напишите программу, которая позволит найти наиболее часто встречающийся элемент массива

При поступлении в институт абитуриенты, получившие двойку на первом экзамене, ко второму недопускаются. В массиве А записаны оценки экзаменующихся.

Подсчитать, сколько человек недопущено ко второму экзамену.
"язык паскаль"

Помогите написать программу на паскаль и блок схему

Найти сумму
1,1-1,2+1,3.......1.n
n- целое, вводится с клавиатуры

Читайте также

1.пользователь вводит натуральное число. Определить среднее арифметическое цифр этого числа.

2.пользователь вводит натуральное число N. Найти сумму всех натуральных чисел от 1 до N.

Требовалось написать программу,при выполнении которой с клавиатуры вводится натуральное число,не превосходящее 10^8, и выводится его первая цифра.Ученик

написал такую программу:
var n:longint;
begin
read(n);
while n>10 do
begin
n:=n mod 10
end;
write(n);
end.


1)Напишите,что выведет эта программа при вводе числа 1984.
2)Приведите пример числа,при вводе которого программа выдаст верный ответ.
3)Найдите в программе все ошибки.

Очень прошу помогите с Паскалем!)

1. Напишите программу, вычисляющую площадь прямоугольника. С клавиатуры вводятся два действительных числа – стороны прямоугольника. Необходимо вычислить его площадь и вывести на экран. Вывод должен быть отформатирован следующим образом: под число отводится 10 знаков, а под вещественную часть – 3.
2. С клавиатуры вводятся 3 целых числа. Определить количество положительных чисел в этом наборе.
3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр.
4. С клавиатуры вводится натуральное число n. Узнайте в нем количество цифр.
5. С клавиатуры вводится натуральное число n. Посчитайте сумму S=1+2+…+n.
6. Даны целые положительные числа N и K. Используя только операции сложения и вычитания, найти частное от деления нацело N на K, а также остаток от этого деления.
7. С клавиатуры вводится натуральное число N. За ним последовательно вводятся данные о росте N учащихся класса. Определите средний рост учащихся всего класса. Попробуйте решить эту задачу без использования массивов.
8. Заполнить элементы массива последовательностью чисел: 2, 5, 10, 17, 26, …
9. Вводится число N, а за ним N целых чисел – элементов массива. Найдите количество отрицательных элементов в этом массиве.
10. С клавиатуры вводится число N. Выведите следующую фигуру (N-строк, на последней строке N звездочек). Подсказка: для решения этой задачи примените конструкцию «цикл в цикле».
*
* *
* * *
* * * *

* * * * * * *
11. Массив заполняется целыми числами до «нуля». Замените все положительные числа массив на противоположные им, а отрицательные возведите в квадрат. Выведите изменившийся массив.
12. На вход программе поступает целое число N. Выведите количество делителей N, включая 1 и само число N. Внимание: для решения этой задачи заведите счетчик и не забудьте сначала занести в него значение 0.

Написать программы на языке С++

1) С клавиатуры вводится 2 числа - целое и вещественное. Программа выводит их сумму на экран.
2) Написать процедуру, которая умножает число типа int на число типа float на число типа double и выводит результат на экран
3) Написать процедуру, которая будет выводить любой текст, являющийся ее аргументом
4) С клавиатуры вводится 5 символов поочередно, программа выводит на экран акроним к слову которая образует эти 5 символов

1)Стороны прямоугольника параллельны осям координат.Одна из вершин имеет координаты (0,0),координаты противоположной вершины задаются с

клавиатуры.Вычислите площадь прямоугольника. 2)С клавиатуры вводится натуральное число.Если оно кратно двум,напишите "четное число",иначе напишите "нечетное число".



Вы находитесь на странице вопроса "с клавиатуры вводятся натуральное число n и вещественное число x. вычислить сумму (-1)^n*(2x)^2n/(2n+1)!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.