Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Пишу программу, должно получится как на 1 картинке, но получается как 2. Что исправить? program t;

10-11 класс

uses crt;
var b:real;
i:integer;
c:array[1..7] of integer;
begin
clrscr;
b:=0;
writeln('Введите температуру ');
for i:=1 to 7 do begin
readln(c[i]);
Writeln(i, ' день=' , c[i]);
b:=b+c[i];
end;
b:=b/7;
write('Средняя температура = ',b);
end.

Lena9589 19 нояб. 2013 г., 13:21:45 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nasty93
19 нояб. 2013 г., 14:23:45 (10 лет назад)

Не очень понял что необходимо но попробуй так
program t;
uses crt;
var b:real;
i:integer;
c:array[1..7] of integer;
begin
clrscr;
b:=0;
writeln('Ведите температуру ');
for i:=1 to 7 do
begin
Write(i,' день=');
read(c[i]);
b:=b+c[i];
end;
b:=b/7;
write('средняя температура= ',b, 'град');
end.

Ответить

Другие вопросы из категории

1)

Цепочка из трех бусин формируется по следующему
правилу: На первом месте в цепочке стоит одна из бусин А, Б, В. На втором –
одна из бусин Б, В, Г. На третьем месте – одна из бусин А, В, Г, не стоящая в
цепочке на первом или втором месте. Какая из следующих цепочек создана по этому
правилу:

Известно, что в буклете 12 страниц, на каждой странице по 24 рядка, а в каждом рядку 32 символа. Вычислить информационный объем буклета, если известно,

что он кодировался однобайтовым способом (т.е для кодирования одного символа использовался 1 байт). Ответ записать в битах

Читайте также

Всем привет, помогите написать программу в паскале, смысл прост. Программа должна переводить число из шестнадцатиричной системы счисления в дестяричную и

наоборот, тоесть после вводе числа- FFF программа должна вывести число 4095 и ниже снова FFF, программа должна быть простая и не слишком умная. Заранее спасибо

дана программа нахождения суммы всех элементов массива. Изменить программу таким образом,чтобы:

a) массив состоял из 15 элементов вещественного типа;
b) значения элементов массива должны меняться в интервале от 0 до 5;
c) в результате выполнения программы должно быть найдено произведение всех элементов массива, а не их сумма

Program massiv;
const n=10;
Var a: array [1..n] of integer;
s,i integer;
Begin
writeln (‘ исходный массив.‘);
For i:= 1 to n do
begin
a [ i] := random (10);
write (‘a[‘i'] =', a[i], '');
end;
s:=0;
For i:= 1 to n do
s:= s+a[i];
Writeln (‘ сумма всех элементов массива S=‘, s);
end.

ПОМОГИТЕ СРОЧНО РЕШИТЬ 1)Какое количество информации несёт сообщение:"Встреча назначена на сентябрь". 2)Какое количество информации

несёт сообщение о том, что встреча назначена на 15 число?

3)Какое количество информации несёт сообщение о том, что встреча назначена на 23 октября в 15:00

4)Какое количество информации несет в себе сообщение о том, что нужная вам программа находится на одной из восьми дискет?

5) Какое количество информации получит второй игрок при игре в крестики-нолики на поле 8x8, после первого хода первого игрока, играющего крестиками?

6) В рулетке общее количество лунок равно 128. Какое количество информации мы получаем в зрительном собщения об остановке шарика в одной из лунок?

7) Происходит выбор одной карты из колоды в 32 карты. Какое количество информации мы получаем в зрительном сообщении о выборе определенной карты?



Вы находитесь на странице вопроса "Пишу программу, должно получится как на 1 картинке, но получается как 2. Что исправить? program t;", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.