Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Можете помочь написать программу?

10-11 класс

Kloun64 10 сент. 2014 г., 14:51:16 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Gorain98
10 сент. 2014 г., 17:24:52 (9 лет назад)

const
  n = 10;

var
  a: array[1..n, 1..n] of integer;
  i, j, k, s: integer;

begin
  Writeln('Сгенерированная матрица');
  for i := 1 to n do
  begin
    for j := 1 to n do
    begin
      a[i, j] := abs(n - i - j + 1);
      Write(a[i, j]:2)
    end;
    Writeln
  end;
  Write('Введите номер столбца (1-10): ');
  Readln(k);
  if not (k in [1..10]) then Writeln('Столбца с таким номером не существует')
  else begin
    s := 0;
    for j := 1 to n do s := s + a[k, j];
    Writeln('Сумма элементов по столбцу ', k, ' равна ', s)
  end
end.

Тестовое решение:

Сгенерированная матрица
 9 8 7 6 5 4 3 2 1 0
 8 7 6 5 4 3 2 1 0 1
 7 6 5 4 3 2 1 0 1 2
 6 5 4 3 2 1 0 1 2 3
 5 4 3 2 1 0 1 2 3 4
 4 3 2 1 0 1 2 3 4 5
 3 2 1 0 1 2 3 4 5 6
 2 1 0 1 2 3 4 5 6 7
 1 0 1 2 3 4 5 6 7 8
 0 1 2 3 4 5 6 7 8 9
Введите номер столбца (1-10): 8
Сумма элементов по столбцу 8 равна 31



Ответить

Другие вопросы из категории

1) Проверить и исправить, если они есть, ошибки в буквосочетаниях: ча, ща, чу, щу, жи, ши. Написать программу, реализующую проверку словарного

диктанта. P.S. Длина слова типа string равна 255 символов 2) Составить алгоритм вычисления среднего арифметического значения температуры за месяц.

Зачем на предприятии нужны информационные системы?а)для того чтобы идти в ногу соЗачем на предприятии нужны информационные системы?а)для того

чтобы идти в ногу со временем
б)для ускорения процессов передачи информации
в)для контроля

Pascal ABC

1. Дан двумерный числовой массив A состоящий из 35*35 элементов. Написать программу для нахождения количества значений элементов массива меньших среднего арифметического значения элементов массива.

2.Дан двумерный числовой массив A состоящий из 15*100 элементов. Написать программу для нахождения количества элементов массива делящихся на 13 без остатка.

Читайте также

Очень вас прошу помочь написать программу.Написать программу-

1)с помощью генератора случайных чисел создать Н числа в диапазоне с [-50;50](длину массива Н надо ввести с клавиатуры)
2)надо вывести сделанный массив на экран
3)нужно вычислить и вывести,какое количество парных чисел
4)и вывести на экран все парные числа.
Очень вас прошу помогите,очень нужно до завтра сделать.Если можете помочь мне,пожалуйста помогите.

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

дан массив из семи элементов написать программу подсчитывающую

среднее второго и предпоследнего элементов массива
дан целочисленный
массив из 10 элементов написать программу находящую сумму элементов
массива красных 3 ил 5
дан целочисленный массив из 30 ти элементов
написать программу которая позволяет найти среднее арифметическое
положительных элементов массива

1) Написать программу для вычисления суммы цифр пятизначного числа , введенного с клавиатура

2) Заданы действительные числа a , b , c и d . Написать программу нахождения полусуммы наименьшего и наибольшего из них.
3) Написать программу для вычисления суммы цифр числа , введенного с клавиатуры

Помогите прошу



Вы находитесь на странице вопроса "Можете помочь написать программу?", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.