Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Задайте массив из 10 элементов с помощью датчика случайных чисел. Замените всё его положительные элементы на наибольший отрицательный элемент.

10-11 класс

Выведите на экран исходный и полученный массив. На Паскале

Ksunyi1 24 нояб. 2014 г., 15:31:10 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Rufinadobryninaaa
24 нояб. 2014 г., 17:47:00 (9 лет назад)

uses crt;
var min,i:integer;
a:array[1..10] of integer;

begin randomize;
for i:=1 to 10 do a[i]:=random(91)-40;
for i:=1 to 10 do write(a[i],' ');
min:=a[1];
for i:=1 to 10 do if min > a[i] then min:=a[i];

for i:=1 to 10 do if a[i]>0 then a[i]:=min;
writeln;
for i:=1 to 10 do write(a[i],' ');

readln;
end.

Ответить

Другие вопросы из категории

Номер 3: все кроме Г... Пожалуйста..
1) Вводится 4 числа. Вывести на экран наибольшую из первых цифр заданных чисел. Например, если a=46, b=831, c=2996, d=486, то напечатать число 8.

Использовать процедуру. - Написать на Паскале.

2) Дан массив A(10,5). Поменять местами элементы первого столбца с элементами столбца, в котором находится максимальный элемент массива. - Написать на Паскале.

3) Вводятся значения трех переменных. Переставить значения. Дополнительные переменные не использовать.
Составить алгоритм.

Читайте также

1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными

индексами. выведите на экран исходный массив и полученное среднее арифметическое.
2. Задайте массив из 10 элементов с помощью датчика случайных чисел. замените все элементы с четными индексами максимальными. Выведите на экран исходный и измененный массивы

1)напишите программу формирования массива размеров 5 х 5 с помощью датчика случайных чисел.замените в нем все четные значения элементов суммой

индексов элементов главной диагонали.Выведите на экран исходный и измененный массивы (программа на языке Паскаля)
2)Составьте программу формирования и вывода на экран одномерного массива, состоящего из удвоенных минимальных элементов строк двумерного массива, заданного с помощью датчика случайных чисел

Помогите пожалуйста

Задать двумерный массив А (7, 7) с
помощью датчика случайных чисел и вывести его на экран в виде таблицы. Затем
удвоить все его элементы и снова вывести на экран. Оформите вывод массива в виде
процедуры.

Помогите, пожалуйста. Паскаль ABC. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите произведение элементов, имеющих

нечетные индексы. Выведите на экран исходный массив и полученное произведение.

Помогите пожалуйста!!!! Задайте массив из 10 элементов с помощью датчика случайных чисел. Замените все элементы с нечетными индексами

на минимальный. Выведите на экран исходный и полученный массивы.



Вы находитесь на странице вопроса "Задайте массив из 10 элементов с помощью датчика случайных чисел. Замените всё его положительные элементы на наибольший отрицательный элемент.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.