Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите пожалуйста!!!! Задайте массив из 10 элементов с помощью датчика случайных чисел. Замените все элементы с нечетными индексами

10-11 класс

на минимальный. Выведите на экран исходный и полученный массивы.

алексноолллллллл 30 апр. 2013 г., 8:38:35 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Jygiygdxs
30 апр. 2013 г., 9:48:35 (11 лет назад)

writeln( 'Src' );
for i := 1 to 10 do begin a[ i ] := random(100); writerln( 'a[ ', i, '] = ', a[ i ] ); if (i = 1) or (a[ i ] < min) then min := a[ i ]; end;
writeln( 'Result' );
for i := 1 to 10 do begin if (odd(i)) then a[ i ] := min; writerln( 'a[ ', i, '] = ', a[ i ] ); end;

Ответить

Другие вопросы из категории

Читайте также

1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными

индексами. выведите на экран исходный массив и полученное среднее арифметическое.
2. Задайте массив из 10 элементов с помощью датчика случайных чисел. замените все элементы с четными индексами максимальными. Выведите на экран исходный и измененный массивы

1)напишите программу формирования массива размеров 5 х 5 с помощью датчика случайных чисел.замените в нем все четные значения элементов суммой

индексов элементов главной диагонали.Выведите на экран исходный и измененный массивы (программа на языке Паскаля)
2)Составьте программу формирования и вывода на экран одномерного массива, состоящего из удвоенных минимальных элементов строк двумерного массива, заданного с помощью датчика случайных чисел

Помогите, пожалуйста. Паскаль ABC. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите произведение элементов, имеющих

нечетные индексы. Выведите на экран исходный массив и полученное произведение.

Помогите, пожалуйста. Паскаль ABC

Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите разность наибольшего и наименьшего элементов. Выведите на экран полученный массив и полученную разность.

Помогите пожалуйста

Задать двумерный массив А (7, 7) с
помощью датчика случайных чисел и вывести его на экран в виде таблицы. Затем
удвоить все его элементы и снова вывести на экран. Оформите вывод массива в виде
процедуры.



Вы находитесь на странице вопроса "Помогите пожалуйста!!!! Задайте массив из 10 элементов с помощью датчика случайных чисел. Замените все элементы с нечетными индексами", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.