Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дано натуральное четырехзначное число,верно ли, что все его цифры различны?

10-11 класс

Bozhena2 02 апр. 2017 г., 3:39:35 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
2131738
02 апр. 2017 г., 5:17:13 (7 лет назад)

var a,b,c,d,e:integer;
begin
read(a);
b:=a mod 10;
a:=a div 10;
c:=a mod 10;
a:=a div 10;
d:=a mod 10;
a:=a div 10;
e:=a mod 10;
if (b<>c) and (b<>d) and (b<>e) and (c<>d) and (c<>e) and (d<>e) then write('net povtorov')
else write('est povtori');
end.

Ответить

Другие вопросы из категории

прошу!!!!!срочно надо!!!ну приииииз!!!! это надо сделать в паскале! пожалуйста!кто нибудь!!!SOS!!!!!!

Задача на строки. в предложении все сочетания символов "ух" или "Ух" заменит на "ах". Посчитать количество слов в предложении.

Паскаль

Составьте программу, которая заполняет массив 10-ю случайными целыми числами в диапазоне [1..20] и выводит на экран элементы массива в нечетными значениями.

Читайте также

4 задачи: ввести натуральное число и определить, верно ли, что сумма цифр равна 10 (через repeat и until)//// ввести натуральное

число и определить, какие цифры встречаются несколько раз (через repeat и until)///

ввести целое число и найти сумму его цифр (через while)

ввести целое число и определить , верно ли, что в его записи есть две одинаковые цифры(через while)

всё через паскаль абс

Решите пожалуйста очень срочно надо

1) Дано четырехзначное число. Верно ли, что среди его цифр есть кратные трем
2) Даны три целых числа. Вывести среднее значение числа (средним числом назовем то, которое меньше наибольшего, но больше наименьшего числа)
3) Напишите эффективную программ, которая по двум данным натуральным числам х и у, не превосходящим 10000, подсчитывает количество натуральных чисел, заканчивающихся нулем, на отрезке [х,у] (включая концы отрезка).

1.Дано двузначное число.Определить: a.какая из его цифр больше,первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число.

Определить,равен ли квадрат этого числа учетверённой сумме кубов его цифр. Например, для числа 48 ответ положительный, для числа 52-отрицательный. 3. Дано двузначное число. Определить: a. кратна ли трём сумма его цифр b. кратна ли сумма его цифр числу a. 4. Дано трёхзначное число Определить,равен ли квадрат этого числа сумме кубов его цифр. 5. Дано двузначное число,определить:входит ли в него цифра 3: входит ли в него цифра a.



Вы находитесь на странице вопроса "Дано натуральное четырехзначное число,верно ли, что все его цифры различны?", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.