Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Даны переменные А, В. Если их произведение отрицательно, то умножить на -2, иначе умножить на 3.

5-9 класс

для паскаля.

IgorekmasterOK 15 мая 2013 г., 10:26:49 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tosiy
15 мая 2013 г., 12:55:11 (10 лет назад)

var a,b:integer;
begin
read(a,b);
if a*b<0 then write (-2*a*b) else write (3*a*b);
end.

+ 0 -
Anna1994546
15 мая 2013 г., 13:57:29 (10 лет назад)

Мой вариант:
uses crt;
var a, b, e, f, s:integer;
begin
write('a='); readln(a);
write('b='); readln(b);
e:=a*b; s:=-2*a*b; f:=3*a*b;
if e<0 then writeln('Произведение отрицательно,то=',s)       
else writeln('Произведение положительно,то=',f);
end.

Ответить

Другие вопросы из категории

помогите пожалуйста )

1. Любой носитель , изначально имеющий один каталог ,который создается операционной системой без участия пользователя , называется :1) Главным 2) Основным 3) Корневым 4) Первым
2. К системному программу обеспечению не относятся :1) Драйверы 2) Антивирусные программы 3) Коммуникационные программы 4) Система программирования
3. На уроке в результате математических действий группа детей из четырех человек получила разные ответы. Миша сказал " Это число 10" , Саша:" Это простое число " . Кристина :" Это нечетное число", а Маша :" У меня получилось 12" . Какое это число , если и девочки и мальчики ошиблись ровно по одному разу? 1) 10 2)12 3)3 4)1
4. Определите количество различных решений в уравнении (А ^ Б ) v (С ^ Г )=1 1) 1 2) 5 3) 7 4 ) 8
5. Десятичное число 25 в некоторой системе счисления записывается как 121 . Найдите основание этой системы счисления . 1) 2 2)3 3)4 4) 5

какой моделью является вербальным?

1.характеристика главного героя в литературе. 2.родословное дерево. 3.правила дорожного ведения. 4.план квартиры 5.инструкция по настройке телевизора.. ответов может быть несколько

Читайте также

даны два числа. Если первое число нечетное, то найти сумму кубов, а иначе - куб суммы. даны три числа. Если хотя бы одно из чи

сел - отрицательное, то найти Iа+ b+cI иначе а+b+c +d в корне.

Даны три числа. Если произведение данных чисел - отрицательное, то каждое число возвести в квадрат, иначе найти модуль каждого числа

ПОМОГИТЕ ОЧЕНЬ ПРОШУ



Вы находитесь на странице вопроса "Даны переменные А, В. Если их произведение отрицательно, то умножить на -2, иначе умножить на 3.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.