Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

С ПОМОЩЬЮ ПАСКАЛЯ

5-9 класс

Начав тренировки, спортсмен в первый день пробежал 10 км. Каждый следующий день он увеличивал дневную норму на 10% от нормы предыдущего дня.
Составить программу, определяющую, какой суммарный путь пробежал спортсмен за 7 дней.

Elenabogomolov 25 мая 2013 г., 22:42:35 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
джама001
25 мая 2013 г., 23:51:47 (10 лет назад)

Решение больше математическое получилось с выводом формулы, там уж сами выберете как вам лучше.
На каждый следующий день спортсмен пробегает в
\frac{100+10}{100} = 1.1
большее расстояние чем в предыдущий.
Т.е. если обобщить:
S_n = 10(1.1)^{n-1}
Расстояние, которое спортсмен пробегает каждый n-ный день.
В итоге, у нас получилась геометрическая прогрессия, где
b_1 = 10; q = 1.1
b_n = 10(1.1)^{n-1}
Чтобы найти сумму первых n членов геометрической прогрессии:
S_n = \frac{b1(1-q^n)}{1 - q} \\
S_7 = \frac{10(1-1.1^7)}{1 - 1.1} = \frac{-10(1.1^7-1)}{-0.1} = 100(1.1^7 - 1)
В программе пишем:
_________________________
var
i:integer;
k:double;
begin
k:=1.1;
for i:=1 to 6 do k:=k*1.1;
writeln(100*(k-1):0:2);
end.
__________________________


+ 0 -
собакахантер888
26 мая 2013 г., 2:50:08 (10 лет назад)

var i,k,m,s:integer;
k1,k2:real;
begin
k:=10;
m:=10;
s:=7;
k1:=k; k2:=k;
for i:=1 to s-1 do begin
k1:=k1+k1*m/100;
k2:=k2+k1;
end;
writeln(k2:0:1);
end.

+ 0 -
Evochkatarabar
26 мая 2013 г., 3:59:21 (10 лет назад)

var
i:integer;
n,s:real;
begin
n:=10;
for i:=1 to 7 do
begin
s:=s+n;
n:=n*1.1
end;
writeln('Путь: ',s)
end.

Ответить

Другие вопросы из категории

Выразите 9Мбайт в битах.
помогите пожалуйста )

1. Любой носитель , изначально имеющий один каталог ,который создается операционной системой без участия пользователя , называется :1) Главным 2) Основным 3) Корневым 4) Первым
2. К системному программу обеспечению не относятся :1) Драйверы 2) Антивирусные программы 3) Коммуникационные программы 4) Система программирования
3. На уроке в результате математических действий группа детей из четырех человек получила разные ответы. Миша сказал " Это число 10" , Саша:" Это простое число " . Кристина :" Это нечетное число", а Маша :" У меня получилось 12" . Какое это число , если и девочки и мальчики ошиблись ровно по одному разу? 1) 10 2)12 3)3 4)1
4. Определите количество различных решений в уравнении (А ^ Б ) v (С ^ Г )=1 1) 1 2) 5 3) 7 4 ) 8
5. Десятичное число 25 в некоторой системе счисления записывается как 121 . Найдите основание этой системы счисления . 1) 2 2)3 3)4 4) 5

какой моделью является вербальным?

1.характеристика главного героя в литературе. 2.родословное дерево. 3.правила дорожного ведения. 4.план квартиры 5.инструкция по настройке телевизора.. ответов может быть несколько

Читайте также

Помогите, с помощью паскаля надо сделать следующее:

Составить программу, решающую следующую задачу: дано трехзначное число. В нем зачеркнули первую цифру слева и приписали ее справа. Вывести полученное число.
Так же:
Составить программу, решающую следующую задачу: дан номер некоторого года (целое положительное число). Определить соотв-щий ему номер столетия, учитывая, что, к примеру, началом 20го столетия был 1901 год. Сам то я знаю как решать, но не смогу записать это в паскаль!

Помогите решить задачи с помощью Паскаля:

1. В массиве все отрицательные элементы переместить в начало массива, а остальные в конец с сохранением порядка следования.
2. Дана последовательность целых чисел, среди чисел есть одинаковые, создать массив различных чисел последовательности и полученный массив отсортировать по возрастанию.

Решить задачи с помощью Паскаля:

1. Заполнить массив из 10 элементов случайными числами в интервале [0..100] и отсортировать его по последней цифре.
2. Заполнить массив из 10 элементов случайными числами в интервале [0..100] и отсортировать первую половину по возрастанию, а вторую- по убыванию. Здесь решать лучше методом выбора.



Вы находитесь на странице вопроса "С ПОМОЩЬЮ ПАСКАЛЯ", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.