Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

адача срочно по Паскалю

5-9 класс

В первой строке 2 числа M,N.Дальше описывается M СТРОК по N символов. Найти строку, которая по сумме больше остальных.
Пример

3 3

2 3 1
6 6 1
1 1 1
Ответ
13

78mihailova 08 июля 2013 г., 10:07:34 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nastya554
08 июля 2013 г., 11:20:29 (10 лет назад)

var 
a:array[1..100,1..100]of integer;
m,n,i,j,s,max:integer;
begin
readln(m,n);
for i:=1 to m do
    begin  s:=0;
        for j:=1 to n do
               begin
                  a[i,j]:=random(100);
                   write(a[i,j]:4);
                   s:=s+a[i,j];
               end;
         if s>max then
            max:=s;
           writeln;
     end;
writeln('S: ',max);
end.

+ 0 -
Asdafds
08 июля 2013 г., 12:53:43 (10 лет назад)

var
a:array [1..10, 1..10] of integer;
i,j,s1,s2,m,n:integer;
begin
writeln('Введите через пробел M, N:');
read(m,n);
randomize;
for i:=1 to m do
begin
for j:=1 to n do
begin
a[i,j]:=random(10);
write(a[i,j],' ')
end;
writeln;
end;
for i:=1 to m do
begin
s2:=0;
for j:=1 to n do
if i=1 then s1:=s1+a[i,j]
else s2:=s2+a[i,j];
if s2>s1 then s1:=s2;
end;
writeln(s1)
end.


+ 0 -
Irahre
08 июля 2013 г., 13:44:09 (10 лет назад)

Вы уверены, что "по N символов" ? В Вашем примере по N чисел в строке, а символов далеко не три...

Ответить

Другие вопросы из категории

Разгодайте шараду.Первый слог-остроконечная вершина горы,второй-поток грязи и камней,а вместе -наименьший логический элемент двумерного цифрового

изображения в растровой графике.Колличество букв в названии этого элемента равно...

А)7; Б)6; В)5; Г)4 ;

какое изображение представляет картину состоящую из графических перментов

1фрактальное
2растровое
3векторноне
4графическое

Читайте также

срочно, составьте пожалуйста блок-схему, вот по паскалю она решена

сама задача звучит так: В каких двузначных числах удвоенная сумма цифр равна их произведению?

надо решить задачу по паскалю) "Чтобы избавиться от простуды необходимо 20 таблеток колдрекса или 30 таблеток аспирина. Сколько порций эскимо можно

купить на эти деньги?"
напишите пожалуйста как составить это в паскале) буду благодарна:)

Помогите написать программу по Паскалю,пожалуйста.

Известно, что коды прописных (заглавных) букв латинского алфавита следуют в таблице непрерывно друг за другом. Коды строчных букв латиницы также следуют непрерывно друг за другом на расстоянии 32 символов от прописных (ниже по таблице) .

Если ord('A') = 65, то ord('A')+32 = 97, и это код строчной буквы «а» , то есть chr(ord('A')+32) = 'а'.

Решенить задачу по паскаль

1.дано число х вычислите қол квадрат
2.имеется число а , число b в 2 раза больше, определить их сумму, числа целые. Срочно



Вы находитесь на странице вопроса "адача срочно по Паскалю", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.