Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите, срочно!!!Задача по паскалю!Заполнить массив из 10 элементов положительных или отрицательных чисел во 2 массив переписать сначала отрицательные а

5-9 класс

потом положительные числа, вывести результат

Mashagreen 18 мая 2014 г., 7:49:29 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
MISHKO7
18 мая 2014 г., 10:19:44 (9 лет назад)

Если я все правильно понял, получается что-то такое:

var a,b:array[1..10] of real;
i,k:integer;
begin
k:=1;
for i:=1 to 10 do readln(a[i]);
for i:=1 to 10 do
if a[i]<0 then
begin
b[k]:=a[i];
write(b[k],' ');
k:=k+1;
end;
for i:=1 to 10 do
if a[i]>=0 then
begin
b[k]:=a[i];
write(b[k],' ');
k:=k+1;
end;
end.

Ответить

Читайте также

решить через паскаль через массивы)) 1.Дан одномерный массив из 10 элементов. Заменить все большие 7 члены массива числом 7. Найти количество

таких членов.

2.Дан массив из 10 элементов. Найти количество элементов с четными индексами.

3.Дан массив из 10 элементов. Найти наибольший элемент массива.

ССССРРРРРРРРРРРРРРЛОООООООООООЧЧЧЧЧЧЧЧНООООООООО!!! 1. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.

Найти сумму элементов данного массива.
2. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.
Найти значение максимального элемента массива.

Решить задачи с помощью Паскаля:

1. Заполнить массив из 10 элементов случайными числами в интервале [0..100] и отсортировать его по последней цифре.
2. Заполнить массив из 10 элементов случайными числами в интервале [0..100] и отсортировать первую половину по возрастанию, а вторую- по убыванию. Здесь решать лучше методом выбора.

1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива.

2. Создать массив A из 10 элементов, заполненный случайным образом числами принадлежащих промежутку (0;20). Вывести полученный массив на экран. Вычислить количество элементов массива, значения которых не превышают среднее арифметическое значений его элементов.



Вы находитесь на странице вопроса "Помогите, срочно!!!Задача по паскалю!Заполнить массив из 10 элементов положительных или отрицательных чисел во 2 массив переписать сначала отрицательные а", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.