Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

помогите решить, если возможно с объяснением

10-11 класс

Katrinat 08 авг. 2013 г., 8:54:32 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Лера080798
08 авг. 2013 г., 11:00:59 (10 лет назад)

В решении & и, || или, ~ не, -> импликация.

 

1. Похоже на правду.

2.

1) ну да.

2) Нам нужно то, что в треугольнике и не в прямоугольнике. C & ~A.

3) Опять тоже самое. C& ~A

3.

1) Распишем импликацию: A -> B = ~A || B

(~(A || ~B) || B) & (~A || B) = ((~A & B) || B) & (~A || B) = (~A & B) & (~A & B) = ~A & B

2)

~(A & B) -> (~A & B) = (A & B) || (~A & B) = B

(A -> B) & B || ~B = (~A || B) & B || B = B || B = B

Итого ответ A & B

3)

~(A & B) -> (~A & B) = (A & B) || (~A & B) = 0

(A -> B) & 0 = 0

Ответить

Читайте также

Помогите решить задачу.

Дан массив А1,.......Аn. найти максимальный и минимальный элементы и поменять их местами. Вот задача которую я делал:

program zadacha;
const
k=50;
var
a:array[1..k] of integer;
n,i:1..k;
c,v,max,min,prom:integer;
begin
for i:=1 to n do begin (здесь выскакивает ошибка о проверки диапазона)
a[i]:=random(50);
write(a[i],' ');
end;
max:=a[1];
min:=a[1];
for i:=1 to n do begin
if a[i]>max then begin
max:=a[i];
c:=i;
end;
if a[i]<min the begin
min:=a[i];
v:=i;
end;
end;
writeln('max=',max,'min=',min);
prom:=max; (вот с этой строчки и до конца помогите решить)
max:=min;
min:=prom;
writeln;
writeln('Полученный массив');
for i:=1 to n do
write(a[i], ' ');
readln;
end.

Помогите решить задачуна паскале.

Возможность отправлять закодированные сообщения во время Второй мировой войны была достаточно важной для союзников. Сообщения всегда отправлялись после их кодирования при помощи известного пароля. Иметь фиксированный пароль было небезопасно, поэтому возникла необходимость часто изменять его. Однако следовало разработать механизм отправления нового пароля. У одного из математиков, работавших в криптографической команде, возникла умная идея - отправить пароль, скрытый в самом сообщении. Интересным моментом было то, что получателю сообщения достаточно было знать только размер пароля, а потом найти его в полученном тексте.

Пароль размера n можно найти поиском в тексте наиболее часто встречаемой подстроки из n символов. После нахождения пароля все подстроки совпадающие с ним, удаляются из текста. Теперь пароль можно использовать для расшифровки сообщения.

Однако Ваша задача будет упрощена. Вам достаточно написать программу, которая по заданному размеру пароля и закодированному сообщению найдет пароль в соответствии с описанным выше алгоритмом.

Рассмотрим пример, в котором размер пароля равен трем (n = 3), а текст сообщения имеет вид baababacb. Паролем будет aba, потому что размер этой подстроки 3, она появляется чаще всего во всем тексте (дважды), а остальные шесть различных подстрок появляются только один раз (baa, aab, bab, bac, acb).

Технические условия

Входные данные

Состоит из нескольких тестов. Каждый тест представляет собой одну строку, в которой находится длина пароля n (0 < n ≤ 10) и закодированное сообщение. Сообщение содержит только прописные буквы латинского алфавита, его длина не более 106 и не меньше n.

Выходные данные

Для каждого теста в отдельной строке следует вывести искомый пароль. Если существует несколько паролей, удовлетворяющих задаче, то вывести лексикографически наименьший.

Помогите решить на паскале

______________________________________
В сказочном Солнечном городе живут трое братьев: Ниф-Ниф, Наф-Наф, и Нуф-Нуф. Известно, что у каждого из них есть какое-то количество денег. Так случилось, что после физкультуры они перепутали пиджаки, в которых и лежали деньги. Однако зная о возможной путанице родители пришили бирки с именами. Помогите определить сколько же денег было до физкультуры у братьев, зная что Нуф-Нуф пришел домой в пиджаке Ниф-Нифа, а Наф-Наф в пиджаке Нуф-Нуфа. Входные данные:

В единственной строке входного потока, через пробел записано три числа в диапазоне от 1 до 10^9. Первое число это количество денег, которое обнаружил Ниф-Ниф в карманах придя домой. Второе - сколько стало у Наф-Нафа. И третье сколько принес домой Нуф-Нуф.

Выходные данные:

В первую строку выходного потока необходимо вывести сколько денег было у Ниф-Нифа, во вторую - сколько у Наф-Нафа, а в третью - сколько у Нуф-Нуфа.

Пример входного файла (input.txt): 32 22 54 Пример выходного файла (output.txt): 54 32 22

Ребят, помогите решить первые 10 заданий. Информатика, логика.

Даю 25 баллов, но если будет решены все 10.

Здравствуйте! Помогите решить задания! Не понимаю программу Кумир, к сожалению, завтра последняя возможность исправить оценку. заранее

спасибо

1. Напечатать числовой ряд: 1,7,13,19,25,31,……….61 с помощью цикла «пока».

2. Написать программу, которая запрашивает число с клавиатуры и сообщает его квадрат, затем спрашивает пользователя «Нужно продолжить работу?», и пользователь отвечаетда/нет. Программа заканчивает свою работу, если пользователь напечатал слово «нет» на очередной вопрос программы, иначе считает и выдаёт ответ дальше.

3. Дан массив из 10-ти чётных натуральных чисел – от 2 до 20.

А) Найдите сумму элементов массива.

Б) Найдите минимальный элемент массива.

4. Дан массив из 15 подряд идущих натуральных чисел, начиная с 50.

А) Найдите произведение элементов массива.

Б) Найдите максимальный элемент массива.



Вы находитесь на странице вопроса "помогите решить, если возможно с объяснением", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.