Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Определить, можно ли квадрат со стороной a поместить в окружность заданного радиуса R?

5-9 класс

Входные данные:
Во входном потоке задано два вещественных числа - радиус окружности R и сторона квадрата a. Значение всех исходных величин не превышает 30000.

Выходные данные:
В выходной поток вывести 'YES' или 'NO'.

Пример входного файла
2 1
Пример выходного файла
YES

Lanagera 02 марта 2015 г., 14:49:49 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tizumka
02 марта 2015 г., 17:16:51 (9 лет назад)

Программа на Паскале:
Program BiFi;
Var R,a:real;
Begin
readln(R,a);
if a<=(R*sqrt(2)) then writeln('Yes');
                        else writeln('NO');
readln;
end.

Ответить

Читайте также

Пожалуйста, решите 2 задачи в паскаль. Очень прошу!!!

1)Дано количество секунд, прошедших с начала суток. Сколько полных часов прошло с начала суток, сколько минут прошло с начала очередного часа и сколько секунд прошло с начала очередной минуты?
2)Сколько квадратов со стороной а поместится в прямоугольнике со сторонами x и y? Вычислите незаполненную площадь

№19. Даны стороны треугольника. Определить является ли этот треугольник: а) равносторонним б) равнобедренным в) прямоугольным.

№20. Даны величины углов треугольника. Определить является ли это треугольник:

а) остроугольным

б) тупоугольным

в) прямоугольным

г) равносторонним

д) равнобедренным.

№21. Определить, какая из двух точек - M1(x1,y1) или M2(x2,y2) - расположена ближе к началу координат. Вывести на экран дисплея координаты этой точки.

№22. Даны действительные числа a, b, c, x, y. Выяснить, пройдет ли кирпич с ребрами a,b,c в прямоугольное отверстие со сторонами x и y. Просовывать кирпич в отверстие разрешается только так, чтобы каждое из его ребер было параллельно или перпендикулярно каждой из сторон отверстия.

№23. Написать программу, которая печатает True или False в зависимости от того, выполняются или нет заданные условия:

а) квадрат заданного трехзначного числа равен кубу суммы цифр этого числа;

б) сумма двух первых цифр заданного четырехзначного числа равна сумме двух его последних цифр;

в) среди цифр заданного трехзначного числа есть одинаковые;

г) среди первых трех цифр из дробной части заданного положительного вещественного числа есть цифра 0.

Треугольник со сторонами Даны длины 3-х отрезков. Из них можно составлять треугольники, соединяя отрезки концами. Нужно

сказать, можно ли получить таким способом равносторонний, равнобедренный или разносторонний треугольники.

Input

Со стандартного устройства ввода вводится через пробел 3 целых положительных числа, не превосходящих 10000 – длины отрезков.

Output

Нужно выдать на стандартное устройство вывода одно из следующих сообщений:

“Triangle is equilateral” – если треугольник равносторонний

“Triangle is isosceles” – если треугольник равнобедренный

“Triangle is scalene” – если треугольник разносторонний

“Triangle is invalid” – если треугольника не существует

Кавычки выводить не нужно.

Sample Input

100 60 80

Sample Output

Triangle is scalene



Вы находитесь на странице вопроса "Определить, можно ли квадрат со стороной a поместить в окружность заданного радиуса R?", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.